diff options
author | Ralph Amissah <ralph.amissah@gmail.com> | 2020-09-26 14:44:34 -0400 |
---|---|---|
committer | Ralph Amissah <ralph.amissah@gmail.com> | 2020-10-19 13:41:43 -0400 |
commit | 124782c1745c4dbfd3dc84f5e50e0214899e39f7 (patch) | |
tree | 7258689c84e5cb4e199685cafb0533374962f5f0 /shell.nix | |
parent | shell.nix (diff) |
nixify step
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 32 |
1 files changed, 15 insertions, 17 deletions
@@ -1,19 +1,17 @@ -{ pkgs ? import <nixpkgs> {} }: - -with pkgs; - -mkShell { - buildInputs = with pkgs; [ - ninja dub - meson git - ldc #ldc dmd gdc - sqlite - validatePkgConfig - #gnumake gcc gdc cmake - #dzen2 +{ pkgs ? import <nixpkgs> { + overlays = [ + (import ./nixDevEnv/overlays/ldcVersion.nix) + (import ./nixDevEnv/overlays/dmdVersion.nix) + ]; } +}: + pkgs.mkShell { + buildInputs = with pkgs; [ + dub + ninja + #meson + dmd + ldc + sqlite + validatePkgConfig ]; - shellHook = '' - echo `ldc2 --version` - ''; - COMPILER = "ldc2"; } |