summaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix40
1 files changed, 20 insertions, 20 deletions
diff --git a/flake.nix b/flake.nix
index fb13f2a..336fb0e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,23 +1,23 @@
{
description = "a sisu like document parser search form";
- inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; # "github:nixos/nixpkgs"; "github:NixOS/nixpkgs/nixpkgs-unstable"; "nixpkgs/nixos-unstable"; "nixpkgs/nixos-21.11";
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
inputs.flake-utils.url = "github:numtide/flake-utils";
- #inputs.d-overlay = {
- # url = "git+file:///home/ralph/grotto/repo/git.repo/projects/doc-reform/packages/nix-flakes/dlang/dlang-nix-flakes";
- # inputs.nixpkgs.follows = "nixpkgs";
- # flake = true;
- #};
+ inputs.d-overlay = {
+ url = "git+file:///home/ralph/grotto/repo/git.repo/projects/doc-reform/packages/nix-flakes/dlang/dlang-nix-flakes";
+ inputs.nixpkgs.follows = "nixpkgs";
+ flake = true;
+ };
outputs = {
self,
nixpkgs,
flake-utils,
- #d-overlay,
+ d-overlay,
} @ inputs: let
pname = "spine_search";
version = "0.12.0";
- shell = ./shell.nix; # ./default.nix;
- devEnv = ./.envrc; # ./shell.nix; # ./default.nix;
- supportedSystems = ["x86_64-linux"]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
+ shell = ./shell.nix;
+ devEnv = ./.envrc;
+ supportedSystems = ["x86_64-linux"];
forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
nixpkgsFor = forAllSystems (system: import nixpkgs {inherit system;}); # nixpkgs instantiated for supported system types
checkPhase = ''
@@ -28,8 +28,8 @@
localOverlay = (final: prev: {
ldc = prev.callPackage ./nix-overlays/ldc { };
dmd = prev.callPackage ./nix-overlays/dmd { };
- dub = prev.callPackage ./nix-overlays/dub { }; # -> ?
- #gdc = prev.callPackage ./nix-overlays/gdc { }; # empty
+ dub = prev.callPackage ./nix-overlays/dub { };
+ #gdc = prev.callPackage ./nix-overlays/gdc { }; # empty
});
pkgsForSystem = system: import nixpkgs {
overlays = [
@@ -60,7 +60,7 @@
inherit shell;
inherit devEnv;
buildInputs = [sqlite];
- nativeBuildInputs = [dub ldc gnumake]; # [ dub dmd ]; [ dub ldc ]; [ dub gdc ];
+ nativeBuildInputs = [dub ldc gnumake];
buildPhase = ''
runHook preBuild
for DC_ in dmd ldmd2 ldc2 gdc gdmd; do
@@ -169,26 +169,26 @@
name = "spine base dev shell";
inherit shell;
inherit devEnv;
+ #nativeBuildInputs = [ ldc dub gnumake ];
#buildInputs = [ sqlite ];
- #nativeBuildInputs = [ dub dmd ldc gdc gnumake ];
packages = [
sqlite
- dub
- #dmd
ldc
+ #dmd
+ dub
gnumake
];
inherit shellHook;
};
- #dsh-d-overlay = d-overlay.devShells.${system}.default;
+ dsh-d-overlay = d-overlay.devShells.${system}.default;
dsh-sqlite = mkShell {
name = "spine dev shell for latex & pdf output";
inherit shell;
inherit devEnv;
packages = [
- dub
- #dmd
ldc
+ #dmd
+ dub
gnumake
sqlite
];
@@ -198,7 +198,7 @@
name = "nixpkgs - ldc - dub";
inherit shell;
inherit devEnv;
- #nativeBuildInputs = [ dub dmd ldc gdc gnumake ];
+ #nativeBuildInputs = [ ldc dub gnumake ];
#buildInputs = [ sqlite ];
packages = with pkgs; [
ldc