aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix27
1 files changed, 14 insertions, 13 deletions
diff --git a/shell.nix b/shell.nix
index 704a2da1..a22a36d4 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,13 +1,15 @@
-#!/usr/bin/env -S nix-shell --pure
-{ pkgs ? import <nixpkgs> {} }:
-pkgs.mkShell {
- buildInputs = [(
- with pkgs; [
+#!/usr/bin/env -S nix-shell --impure
+#!nix-shell -i bash
+{pkgs ? import <nixpkgs> {}}:
+with pkgs;
+ mkShell {
+ buildInputs = [
ruby_3_1
rubyPackages_3_1.rake
rubyPackages_3_1.sqlite3
rubyPackages_3_1.thor
sqlite
+ graphicsmagick
unzip
xz
zip
@@ -15,13 +17,12 @@ pkgs.mkShell {
#texlive-combined-full
nixFlakes
validatePkgConfig
+ nix-output-monitor
+ nix-tree
jq
git
- ]
- )];
- shellHook = ''
- if [[ -e ".envrc" ]]; then
- source .envrc
- fi
- '';
-}
+ #starship
+ ];
+ shellHook = ''
+ '';
+ }