summaryrefslogtreecommitdiffstats
path: root/bin/sisu
blob: 4914890c502f2d889f563c74c0bc6560a0a225a1 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
#!/usr/bin/env ruby
# encoding: utf-8
#SiSU: copyright (C) 1997 - 2013 Ralph Amissah; License GPL, see appended program information
begin
  def ruby_version_ok?(base_version)
    @v ||=RUBY_VERSION.scan(/\d+/)
    vb=base_version.scan(/\d+/)
    if @v[0].to_i <  vb[0].to_i \
    or @v[0].to_i == vb[0].to_i \
    && @v[1].to_i <  vb[1].to_i \
    or @v[0].to_i == vb[0].to_i \
    && @v[1].to_i == vb[1].to_i \
    && @v[1].to_i <  vb[2].to_i
      raise "Please, use Ruby#{vb} or later, current Ruby #{RUBY_VERSION}"
    else check_incompatible_ruby_build?
    end
  end
  def check_incompatible_ruby_build?
    require 'rbconfig'
    e=Config::CONFIG
    if RUBY_VERSION == '1.9.2' \
    && e['PATCHLEVEL'].to_i < 180
      raise <<WOK
There are known issues with early versions of ruby1.9.2.
Please, use Ruby 1.9.2p180 or later,
current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
#{%x{ruby -v}.strip.to_s}

WOK
    end
  end
  def check_sisu_legacy_ruby_version?
    rbv_sisu_legacy='1.9.2' #'1.8.7'
    ruby_version_ok?(rbv_sisu_legacy)
  end
  def check_sisu_stable_ruby_version?
    rbv_sisu_stable='1.9.2'
    ruby_version_ok?(rbv_sisu_stable)
  end
  def check_sisu_dev_ruby_version?
    rbv_sisu_dev='1.9.2'
    ruby_version_ok?(rbv_sisu_dev)
  end
  def require_hub_path(sisu_path_specified_lib_)
    sisu_path_lib=if sisu_path_specified_lib_ \
    && FileTest.file?("#{sisu_path_specified_lib_}/#{SiSU_lib}/hub.rb")
      "#{sisu_path_specified_lib_}/#{SiSU_lib}"
    else
      SiSU_lib
    end
  end
#% sisu branch
  $VERBOSE=nil
  $KCODE='u' if RUBY_VERSION < '1.9'
  argv=$*
  SiSU_called_from_directory=Dir.pwd
  if $0 !~/\bsisu[45]$/
    SiSU_version_dir=case argv.inspect
    when /"(?:--v4)"/
      check_sisu_stable_ruby_version?
      'v4'
    when /"(?:--v5)"/
      check_sisu_stable_ruby_version?
      'v5'
    when /"(?:--dev)"/
      check_sisu_dev_ruby_version?
      'v5'
    else
      check_sisu_stable_ruby_version?
      'v4'
    end
  else
    SiSU_version_dir=case $0
    when /\bsisu4$/
      check_sisu_stable_ruby_version?
      'v4'
    when /\bsisu5$/
      check_sisu_stable_ruby_version?
      'v5'
    else
      check_sisu_stable_ruby_version?
      'v4'
    end
  end
#% $0 File.expand_path($0)
  e=Config::CONFIG
  SiSU_path_base=if $0 =~ /^#{e['bindir']}\/sisu[45]?$/
    nil
  elsif $0 !~ /^#{e['bindir']}\/sisu[45]?$/ \
  && File.expand_path($0) =~/bin\/sisu[45]?$/ \
  && FileTest.file?($0)
    File.expand_path($0).sub(/\/bin\/sisu[45]?$/,'')
  else
    nil
  end
  SiSU_lib="sisu/#{SiSU_version_dir}"
  sisu_path_specified_lib_=SiSU_path_base \
  ? File.expand_path($0).sub(/bin\/sisu[45]?$/,'lib')
  : nil
  SiSU_path_specified_Version_=SiSU_path_base \
  ? "#{SiSU_path_base}/data/sisu/#{SiSU_version_dir}/v/version.yml"
  : nil
  SiSU_path_lib="#{require_hub_path(sisu_path_specified_lib_)}"
#% $*
  require "#{SiSU_path_lib}/hub"
  lng_lst = %w[am bg bn br ca cs cy da de el en eo es et eu fi fr ga gl he hi hr hy ia is it la lo lt lv ml mr nl nn no oc pl pt pt_BR ro ru sa se sk sl sq sr sv ta te th tk tr uk ur us vi]
  lng_lst_rgx=lng_lst.join('|')
  argv_sub_files={}
  argv_sub_mods=[]
  argv.each do |x|
    if x =~/^-+/
      argv_sub_mods << x
    elsif x =~/\.ss[tm]/
      if x =~/\//
        markup_path,markup_file =(/(\S+\/)((?:#{lng_lst_rgx})?[^\/]+)/).match(x)[1,2]
        if not argv_sub_files[markup_path]
          argv_sub_files[markup_path]=[]
        end
        argv_sub_files[markup_path] << markup_file
      else
        if not argv_sub_files['./']
          argv_sub_files['./']=[]
        end
        argv_sub_files['./'] << x
      end
    end
  end
  if argv_sub_files.length > 0
    argv_sub_files.each_pair do |markup_dir,markup_file|
      $sisu_document_markup_directory=markup_dir.gsub(/\/$/,'')
      argv_sub=argv_sub_mods + markup_file
      if FileTest.directory?(markup_dir)
        system("cd #{markup_dir}")
        Dir.chdir(markup_dir)
        $sisu_document_markup_directory_base_fixed_path=Dir.pwd.gsub(/\/(?:#{lng_lst_rgx})$/,'')
        SiSU::HubMaster.new(argv_sub)
        Dir.chdir(SiSU_called_from_directory)
        system("cd #{SiSU_called_from_directory}")
      elsif markup_dir =~/https?:/
        markup_file.each do |mf|
          (FileTest.file?(mf)) \
          ? (puts 'requested remote file already exists in current directory ' + Dir.pwd + ' using ' + mf)
          : (system("wget #{markup_dir}/#{mf}"))
        end
        $sisu_document_markup_directory_base_fixed_path=Dir.pwd.gsub(/\/(?:#{lng_lst_rgx})$/,'')
        argv_sub=argv_sub_mods + markup_file
        SiSU::HubMaster.new(argv_sub)
      else p "Error directory specified #{markup_dir} not found"
      end
    end
  else
    $sisu_document_markup_directory=Dir.pwd.gsub(/\/$/,'')
    $sisu_document_markup_directory_base_fixed_path=Dir.pwd.gsub(/(^|\/)(?:#{lng_lst_rgx})$/,'')
    SiSU::HubMaster.new(argv)
  end
rescue
  STDERR.puts 'ERROR'
  STDERR.puts $!
  STDERR.puts $@
  require 'rbconfig'
  e=Config::CONFIG
  puts %{
                   #{%x{ruby -v}.strip.to_s}
                   #{RUBY_VERSION}
    ruby version:  #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
    ruby named:    #{e['ruby_version']}
    rubylib:       #{e['rubylibdir']}
    rubylib local: #{e['sitelibdir']}
  }
  system(%{echo "
    system RUBYPATH: ${RUBYPATH}
    system RUBYLIB: ${RUBYLIB}
  "})
end
__END__

 * Name: SiSU

 * Description: a framework for document structuring, publishing and search

 * Author: Ralph Amissah

 * Copyright: (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006,
   2007, 2008, 2009, 2010, 2011, 2012, 2013 Ralph Amissah, All Rights Reserved.

 * License: GPL 3 or later:

   SiSU, a framework for document structuring, publishing and search

   Copyright (C) Ralph Amissah

   This program is free software: you can redistribute it and/or modify it
   under the terms of the GNU General Public License as published by the Free
   Software Foundation, either version 3 of the License, or (at your option)
   any later version.

   This program is distributed in the hope that it will be useful, but WITHOUT
   ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
   FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
   more details.

   You should have received a copy of the GNU General Public License along with
   this program. If not, see <http://www.gnu.org/licenses/>.

   If you have Internet connection, the latest version of the GPL should be
   available at these locations:
   <http://www.fsf.org/licensing/licenses/gpl.html>
   <http://www.gnu.org/licenses/gpl.html>

   <http://www.sisudoc.org/sisu/en/manifest/gpl.fsf.html>

 * SiSU uses:
   * Standard SiSU markup syntax,
   * Standard SiSU meta-markup syntax, and the
   * Standard SiSU object citation numbering and system

 * Hompages:
   <http://www.jus.uio.no/sisu>
   <http://www.sisudoc.org>

 * Download:
   <http://www.sisudoc.org/sisu/en/SiSU/download.html>

 * Git
   <http://sources.sisudoc.org/gitweb/?p=code/sisu.git;a=summary>
   <http://sources.sisudoc.org/?p=code/sisu.git;a=blob;f=bin/sisu;hb=HEAD>

 * Ralph Amissah
   <ralph@amissah.com>
   <ralph.amissah@gmail.com>