summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-03-24 01:49:33 +0000
committerRalph Amissah <ralph@amissah.com>2011-03-24 13:14:34 +0000
commit9e82ccef5eeb3228c7c958b049de4cbbf6b0d8a2 (patch)
treeecb8fccc7f527f6f5b6f98b36a5db973f94a5ad3
parentv2, v3: vim syntax highlighting, fix typo (diff)
downloadsisu-9e82ccef5eeb3228c7c958b049de4cbbf6b0d8a2.zip
sisu-9e82ccef5eeb3228c7c958b049de4cbbf6b0d8a2.tar.xz
v3, v2: bin/sisu*: v3 development ruby >=1.9.2p180; v2 maintenance ruby >=1.8.7
* bin/sisu* version checks
-rw-r--r--bin/sisu92
-rw-r--r--bin/sisu393
-rw-r--r--bin/sisu_termsheet80
-rw-r--r--bin/sisu_webrick80
-rw-r--r--data/doc/sisu/CHANGELOG_v29
-rw-r--r--data/doc/sisu/CHANGELOG_v38
-rw-r--r--data/sisu/v2/v/version.yml6
-rw-r--r--data/sisu/v3/v/version.yml4
8 files changed, 278 insertions, 94 deletions
diff --git a/bin/sisu b/bin/sisu
index 5da1751..ceeebd6 100644
--- a/bin/sisu
+++ b/bin/sisu
@@ -1,37 +1,73 @@
#!/usr/bin/env ruby
# encoding: utf-8
#SiSU: copyright (C) 1997 - 2011 Ralph Amissah; License GPL, see appended program information
-#raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
-def check_sisu_stable_ruby_version?
- rbv_sisu_stable='1.8.7'
- if RUBY_VERSION < rbv_sisu_stable
- raise "Please, use Ruby#{rbv_sisu_stable} or later, current Ruby #{RUBY_VERSION}"
+begin
+ def check_sisu_stable_ruby_version?
+ rbv_sisu_stable='1.8.7'
+ if RUBY_VERSION < rbv_sisu_stable
+ raise "Please, use Ruby#{rbv_sisu_stable} or later, current Ruby #{RUBY_VERSION}"
+ else check_incompatible_ruby_build?
+ end
end
-end
-def check_sisu_dev_ruby_version?
- rbv_sisu_dev='1.9.2'
- if RUBY_VERSION < rbv_sisu_dev
- raise "Please, use Ruby#{rbv_sisu_dev} or later, current Ruby #{RUBY_VERSION}"
+ def check_sisu_dev_ruby_version?
+ rbv_sisu_dev='1.9.2'
+ if RUBY_VERSION < rbv_sisu_dev
+ raise "Please, use Ruby#{rbv_sisu_dev} or later, current Ruby #{RUBY_VERSION}"
+ else check_incompatible_ruby_build?
+ end
end
+ def check_incompatible_ruby_build?
+ require 'rbconfig'
+ e=Config::CONFIG
+ if RUBY_VERSION == '1.9.2' \
+ and e['PATCHLEVEL'].to_i < 180
+ raise <<WOK
+There are known issues with early versions of ruby1.9.2.
+Please, use Ruby 1.9.2p180 or later,
+current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
+#{%x{ruby -v}.strip.to_s}
+
+WOK
+ end
+ end
+ $VERBOSE=nil
+ $KCODE='u' if RUBY_VERSION < '1.9'
+ argv=$*
+ SiSU_version_dir=case argv.inspect
+ when /--v2/
+ check_sisu_stable_ruby_version?
+ 'v2'
+ when /--v3/
+ check_sisu_dev_ruby_version?
+ 'v3'
+ when /--dev/
+ check_sisu_dev_ruby_version?
+ 'v3'
+ else
+ check_sisu_stable_ruby_version?
+ 'v2'
+ end
+ SiSU_lib="sisu/#{SiSU_version_dir}"
+ require "#{SiSU_lib}/hub"
+rescue
+ STDERR.puts 'ERROR'
+ STDERR.puts $!
+ STDERR.puts $@
+ require 'rbconfig'
+ e=Config::CONFIG
+ puts %{
+ #{%x{ruby -v}.strip.to_s}
+ #{RUBY_VERSION}
+ ruby version: #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
+ ruby named: #{e['ruby_version']}
+ rubylib: #{e['rubylibdir']}
+ rubylib local: #{e['sitelibdir']}
+ }
+ system(%{echo "
+ system RUBYPATH: ${RUBYPATH}
+ system RUBYLIB: ${RUBYLIB}
+ "})
end
-check_sisu_stable_ruby_version?
-$VERBOSE=nil
-$KCODE='u' if RUBY_VERSION < '1.9'
-argv=$*
-SiSU_version_dir=case argv.inspect
-when /--v2/
- 'v2'
-when /--v3/
- check_sisu_dev_ruby_version?
- 'v3'
-when /--dev/
- check_sisu_dev_ruby_version?
- 'v3'
-else
- 'v2'
-end
-SiSU_lib="sisu/#{SiSU_version_dir}"
-require "#{SiSU_lib}/hub"
__END__
* Name: SiSU
diff --git a/bin/sisu3 b/bin/sisu3
index 359a874..e324637 100644
--- a/bin/sisu3
+++ b/bin/sisu3
@@ -1,38 +1,73 @@
#!/usr/bin/env ruby
# encoding: utf-8
#SiSU: copyright (C) 1997 - 2011 Ralph Amissah; License GPL, see appended program information
-#raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
-def check_sisu_stable_ruby_version?
- rbv_sisu_stable='1.8.7'
- if RUBY_VERSION < rbv_sisu_stable
- raise "Please, use Ruby#{rbv_sisu_stable} or later, current Ruby #{RUBY_VERSION}"
+begin
+ def check_sisu_stable_ruby_version?
+ rbv_sisu_stable='1.8.7'
+ if RUBY_VERSION < rbv_sisu_stable
+ raise "Please, use Ruby#{rbv_sisu_stable} or later, current Ruby #{RUBY_VERSION}"
+ else check_incompatible_ruby_build?
+ end
end
-end
-def check_sisu_dev_ruby_version?
- rbv_sisu_dev='1.9.2'
- if RUBY_VERSION < rbv_sisu_dev
- raise "Please, use Ruby#{rbv_sisu_dev} or later, current Ruby #{RUBY_VERSION}"
+ def check_sisu_dev_ruby_version?
+ rbv_sisu_dev='1.9.2'
+ if RUBY_VERSION < rbv_sisu_dev
+ raise "Please, use Ruby#{rbv_sisu_dev} or later, current Ruby #{RUBY_VERSION}"
+ else check_incompatible_ruby_build?
+ end
end
+ def check_incompatible_ruby_build?
+ require 'rbconfig'
+ e=Config::CONFIG
+ if RUBY_VERSION == '1.9.2' \
+ and e['PATCHLEVEL'].to_i < 180
+ raise <<WOK
+There are known issues with early versions of ruby1.9.2.
+Please, use Ruby 1.9.2p180 or later,
+current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
+#{%x{ruby -v}.strip.to_s}
+
+WOK
+ end
+ end
+ $VERBOSE=nil
+ $KCODE='u' if RUBY_VERSION < '1.9'
+ argv=$*
+ SiSU_version_dir=case argv.inspect
+ when /--v2/
+ check_sisu_stable_ruby_version?
+ 'v2'
+ when /--v3/
+ check_sisu_dev_ruby_version?
+ 'v3'
+ when /--dev/
+ check_sisu_dev_ruby_version?
+ 'v3'
+ else
+ check_sisu_dev_ruby_version?
+ 'v3'
+ end
+ SiSU_lib="sisu/#{SiSU_version_dir}"
+ require "#{SiSU_lib}/hub"
+rescue
+ STDERR.puts 'ERROR'
+ STDERR.puts $!
+ STDERR.puts $@
+ require 'rbconfig'
+ e=Config::CONFIG
+ puts %{
+ #{%x{ruby -v}.strip.to_s}
+ #{RUBY_VERSION}
+ ruby version: #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
+ ruby named: #{e['ruby_version']}
+ rubylib: #{e['rubylibdir']}
+ rubylib local: #{e['sitelibdir']}
+ }
+ system(%{echo "
+ system RUBYPATH: ${RUBYPATH}
+ system RUBYLIB: ${RUBYLIB}
+ "})
end
-check_sisu_stable_ruby_version?
-$VERBOSE=nil
-$KCODE='u' if RUBY_VERSION < '1.9'
-argv=$*
-SiSU_version_dir=case argv.inspect
-when /--v2/
- 'v2'
-when /--v3/
- check_sisu_dev_ruby_version?
- 'v3'
-when /--dev/
- check_sisu_dev_ruby_version?
- 'v3'
-else
- check_sisu_dev_ruby_version?
- 'v3'
-end
-SiSU_lib="sisu/#{SiSU_version_dir}"
-require "#{SiSU_lib}/hub"
__END__
* Name: SiSU
diff --git a/bin/sisu_termsheet b/bin/sisu_termsheet
index 47af2dc..1031819 100644
--- a/bin/sisu_termsheet
+++ b/bin/sisu_termsheet
@@ -1,22 +1,72 @@
#!/usr/bin/env ruby
# encoding: utf-8
#SiSU: copyright (C) 1997 - 2011 Ralph Amissah; License GPL, see appended program information
-raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
-#raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'
-$VERBOSE=nil
-argv=$*
-SiSU_version_dir=case argv.inspect
-when /--v2/
- 'v2'
-when /--v3/
- 'v3'
-when /--dev/
- 'v3'
-else
- 'v2'
+begin
+ def check_sisu_stable_ruby_version?
+ rbv_sisu_stable='1.8.7'
+ if RUBY_VERSION < rbv_sisu_stable
+ raise "Please, use Ruby#{rbv_sisu_stable} or later, current Ruby #{RUBY_VERSION}"
+ else check_incompatible_ruby_build?
+ end
+ end
+ def check_sisu_dev_ruby_version?
+ rbv_sisu_dev='1.9.2'
+ if RUBY_VERSION < rbv_sisu_dev
+ raise "Please, use Ruby#{rbv_sisu_dev} or later, current Ruby #{RUBY_VERSION}"
+ else check_incompatible_ruby_build?
+ end
+ end
+ def check_incompatible_ruby_build?
+ require 'rbconfig'
+ e=Config::CONFIG
+ if RUBY_VERSION == '1.9.2' \
+ and e['PATCHLEVEL'].to_i < 180
+ raise <<WOK
+There are known issues with early versions of ruby1.9.2.
+Please, use Ruby 1.9.2p180 or later,
+current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
+#{%x{ruby -v}.strip.to_s}
+
+WOK
+ end
+ end
+ $VERBOSE=nil
+ argv=$*
+ SiSU_version_dir=case argv.inspect
+ when /--v2/
+ check_sisu_stable_ruby_version?
+ 'v2'
+ when /--v3/
+ check_sisu_dev_ruby_version?
+ 'v3'
+ when /--dev/
+ check_sisu_dev_ruby_version?
+ 'v3'
+ else
+ check_sisu_stable_ruby_version?
+ 'v2'
+ end
+ SiSU_lib="sisu/#{SiSU_version_dir}"
+ require "#{SiSU_lib}/termsheet"
+rescue
+ STDERR.puts 'ERROR'
+ STDERR.puts $!
+ STDERR.puts $@
+ require 'rbconfig'
+ e=Config::CONFIG
+ puts %{
+ #{%x{ruby -v}.strip.to_s}
+ #{RUBY_VERSION}
+ ruby version: #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
+ ruby named: #{e['ruby_version']}
+ rubylib: #{e['rubylibdir']}
+ rubylib local: #{e['sitelibdir']}
+ }
+ system(%{echo "
+ system RUBYPATH: ${RUBYPATH}
+ system RUBYLIB: ${RUBYLIB}
+ "})
end
-SiSU_lib="sisu/#{SiSU_version_dir}"
-require "#{SiSU_lib}/termsheet"
__END__
* Name: SiSU
diff --git a/bin/sisu_webrick b/bin/sisu_webrick
index 1b2a724..8f79a51 100644
--- a/bin/sisu_webrick
+++ b/bin/sisu_webrick
@@ -1,22 +1,72 @@
#!/usr/bin/env ruby
# encoding: utf-8
#SiSU: copyright (C) 1997 - 2011 Ralph Amissah; License GPL, see appended program information
-raise "Please, use Ruby1.8 (1.8.4 or later), current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4' or RUBY_VERSION > '1.9'
-#raise "Please, use Ruby1.8.4 or later, current Ruby #{RUBY_VERSION}" if RUBY_VERSION < '1.8.4'
-$VERBOSE=nil
-argv=$*
-SiSU_version_dir=case argv.inspect
-when /--v2/
- 'v2'
-when /--v3/
- 'v3'
-when /--dev/
- 'v3'
-else
- 'v2'
+begin
+ def check_sisu_stable_ruby_version?
+ rbv_sisu_stable='1.8.7'
+ if RUBY_VERSION < rbv_sisu_stable
+ raise "Please, use Ruby#{rbv_sisu_stable} or later, current Ruby #{RUBY_VERSION}"
+ else check_incompatible_ruby_build?
+ end
+ end
+ def check_sisu_dev_ruby_version?
+ rbv_sisu_dev='1.9.2'
+ if RUBY_VERSION < rbv_sisu_dev
+ raise "Please, use Ruby#{rbv_sisu_dev} or later, current Ruby #{RUBY_VERSION}"
+ else check_incompatible_ruby_build?
+ end
+ end
+ def check_incompatible_ruby_build?
+ require 'rbconfig'
+ e=Config::CONFIG
+ if RUBY_VERSION == '1.9.2' \
+ and e['PATCHLEVEL'].to_i < 180
+ raise <<WOK
+There are known issues with early versions of ruby1.9.2.
+Please, use Ruby 1.9.2p180 or later,
+current version #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
+#{%x{ruby -v}.strip.to_s}
+
+WOK
+ end
+ end
+ $VERBOSE=nil
+ argv=$*
+ SiSU_version_dir=case argv.inspect
+ when /--v2/
+ check_sisu_stable_ruby_version?
+ 'v2'
+ when /--v3/
+ check_sisu_dev_ruby_version?
+ 'v3'
+ when /--dev/
+ check_sisu_dev_ruby_version?
+ 'v3'
+ else
+ check_sisu_stable_ruby_version?
+ 'v2'
+ end
+ SiSU_lib="sisu/#{SiSU_version_dir}"
+ require "#{SiSU_lib}/webrick"
+rescue
+ STDERR.puts 'ERROR'
+ STDERR.puts $!
+ STDERR.puts $@
+ require 'rbconfig'
+ e=Config::CONFIG
+ puts %{
+ #{%x{ruby -v}.strip.to_s}
+ #{RUBY_VERSION}
+ ruby version: #{e['RUBY_PROGRAM_VERSION']}p#{e['PATCHLEVEL']}
+ ruby named: #{e['ruby_version']}
+ rubylib: #{e['rubylibdir']}
+ rubylib local: #{e['sitelibdir']}
+ }
+ system(%{echo "
+ system RUBYPATH: ${RUBYPATH}
+ system RUBYLIB: ${RUBYLIB}
+ "})
end
-SiSU_lib="sisu/#{SiSU_version_dir}"
-require "#{SiSU_lib}/webrick"
__END__
* Name: SiSU
diff --git a/data/doc/sisu/CHANGELOG_v2 b/data/doc/sisu/CHANGELOG_v2
index 313a989..92868dc 100644
--- a/data/doc/sisu/CHANGELOG_v2
+++ b/data/doc/sisu/CHANGELOG_v2
@@ -12,9 +12,16 @@ Reverse Chronological:
%% STABLE Branch
-%% 2.8.3.orig.tar.gz (2011-03-20:11/7) [see 3.0.5]
+%% 2.9.0.orig.tar.gz (2011-03-23:12/3) [see 3.0.5]
http://git.sisudoc.org/?p=code/sisu.git;a=shortlog;h=refs/tags/debian/3.0.5-1
+ * move to ruby >=1.9.2p180: simplify development of v3 and maintenance of v2
+ * bin/sisu demand ruby >=1.9.2p180 (version checks)
+ * debian/control, dependencies
+ [enforcing use of ruby >= 1.9.2 reason for version bump, note should at
+ least be v1.9.2p180, when issues in earlier versions of ruby-1.9.2 were
+ first observed to be gone]
+
* vim syntax highlighting, fix typo
%% 2.8.2.orig.tar.gz (2011-03-11:10/5) [see 3.0.3]
diff --git a/data/doc/sisu/CHANGELOG_v3 b/data/doc/sisu/CHANGELOG_v3
index 6ae1684..192a830 100644
--- a/data/doc/sisu/CHANGELOG_v3
+++ b/data/doc/sisu/CHANGELOG_v3
@@ -13,13 +13,19 @@ Reverse Chronological:
%% Development branch UNSTABLE
v3 branch once stable will supersede & replace current stable v2 branch
-%% 3.0.5.orig.tar.gz (2011-03-20:11/7)
+%% 3.0.5.orig.tar.gz (2011-03-23:12/3)
http://git.sisudoc.org/?p=code/sisu.git;a=log;h=refs/tags/debian/3.0.5-1
http://www.jus.uio.no/sisu/pkg/src/sisu_3.0.5.orig.tar.gz
sisu_3.0.5.orig.tar.gz
sisu_3.0.5-1.dsc
sisu_3.0.5-1.debian.tar.gz
+ * move to ruby >=1.9.2p180: simplify development of v3 and maintenance of v2
+ * bin/sisu demand ruby >=1.9.2p180 (version checks)
+ * debian/control, dependencies
+ [note should at least be v1.9.2p180, when issues in earlier versions of
+ ruby-1.9.2 were first observed to be gone]
+
* vim syntax highlighting, fix typo
%% 3.0.4.orig.tar.gz (2011-03-11:10/5)
diff --git a/data/sisu/v2/v/version.yml b/data/sisu/v2/v/version.yml
index bb6a21b..be98c78 100644
--- a/data/sisu/v2/v/version.yml
+++ b/data/sisu/v2/v/version.yml
@@ -1,5 +1,5 @@
---
-:version: 2.8.3
-:date_stamp: 2011w11/7
-:date: "2011-03-20"
+:version: 2.9.0
+:date_stamp: 2011w12/3
+:date: "2011-03-23"
:project: SiSU
diff --git a/data/sisu/v3/v/version.yml b/data/sisu/v3/v/version.yml
index ef6be26..4baf491 100644
--- a/data/sisu/v3/v/version.yml
+++ b/data/sisu/v3/v/version.yml
@@ -1,5 +1,5 @@
---
:version: 3.0.5-beta-rb1.9.2p180
-:date_stamp: 2011w11/7
-:date: "2011-03-20"
+:date_stamp: 2011w12/3
+:date: "2011-03-23"
:project: SiSU