#!/usr/bin/env -S nix-shell
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
  buildInputs = with pkgs; [
    (import ./nix/pkglst/shell-pkgs.nix { inherit pkgs; })
  ];
  buildPhase = "nix build -f default.nix";
  shellHook = ''
    echo "built spine @ ./result/bin/spine"
    #nix-instantiate | nix show-derivation | jq
  '';
}