diff options
Diffstat (limited to 'spine.nix')
-rwxr-xr-x | spine.nix | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -1,6 +1,7 @@ #!/usr/bin/env -S nix-build { pkgs ? import <nixpkgs> {}, stdenv ? pkgs.stdenv, + lib ? pkgs.lib, ldc ? null, dcompiler ? pkgs.ldc, dub ? pkgs.dub @@ -9,7 +10,7 @@ assert dcompiler != null; #with import ./nix/mkDub.nix { inherit pkgs; }; with ( # mkDub.nix assert dcompiler != null; - with stdenv; + with stdenv lib; let # Filter function to remove the .dub package folder from src filterDub = name: type: let baseName = baseNameOf (toString name); in ! ( |