diff options
Diffstat (limited to 'shell.nix')
-rwxr-xr-x | shell.nix | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -4,12 +4,14 @@ with pkgs; mkShell { buildInputs = [ + #nix direnv nixVersions.unstable #nixFlakes nix-prefetch-git validatePkgConfig nix-tree jq nix-output-monitor git + gnumake ps ### d_build_related dub @@ -91,6 +93,12 @@ mkShell { nix-build . --no-out-link | xargs -o nix-tree nix-tree --derivation .#default + nix flake update && nix flake check --show-trace && nix flake show && nix develop .#devShell + nix build .#default --print-build-logs + + - nix build .#spine-dmd --print-build-logs + - nix build .#spine-ldc --print-build-logs + - nix build .#spine-gdc --print-build-logs " #echo "ldc `${pkgs.ldc}/bin/ldc2 -v`" ''; |