diff options
author | Ralph Amissah <ralph.amissah@gmail.com> | 2022-07-31 15:44:56 -0400 |
---|---|---|
committer | Ralph Amissah <ralph.amissah@gmail.com> | 2022-08-03 19:18:15 -0400 |
commit | 934b830f804c1acae1e5f2f55207a1f428244f1f (patch) | |
tree | 8b55d1cbc25cbaf59e2ac94db51c809b9f1cc1ab /shell.nix | |
parent | ocn metaverse, rearrange (diff) |
org nix adjust
Diffstat (limited to 'shell.nix')
-rwxr-xr-x | shell.nix | 45 |
1 files changed, 44 insertions, 1 deletions
@@ -4,11 +4,13 @@ with pkgs; mkShell { buildInputs = [ ### nix_related + direnv nixFlakes nix-prefetch-git validatePkgConfig jq git + #ps ### d_build_related ## package manager dub @@ -45,9 +47,50 @@ mkShell { starship ]; shellHook = '' - if [[ -e ".envrc" ]]; then + if [[ -f ".envrc" ]]; then source .envrc fi eval "$(starship init bash)" ''; } + +# - shell.nix -I .envrc +# - shell.nix -I .envrc --pure +# - nix-shell -I nixpkgs=/nixpkgs-ra/nixpkgs --pure +# - nix-shell -p "with import /nixpkgs-ra/nixpkgs {}; ldc" --pure +# - nix-shell -p "with import /nixpkgs-ra/nixpkgs {}; [dub ldc]" --pure + +# - nix-shell -p nixFlakes +# - nix-shell -p nixFlakes --pure +# - nix-shell -p nixFlakes --pure -p "with import /nixpkgs-ra/nixpkgs {}; [dub ldc]" +# - nix-shell shell.nix direnv: export +IN_NIX_SHELL +# - nix-shell shell.nix + +# - nix-build -I nixpkgs=/nixpkgs-ra/nixpkgs --pure +# - nix-build -I .envrc --pure +# - nix-build default.nix -I .envrc && results/bin/spine -v + +# - nix-instantiate | nix show-derivation | jq +# - nix-instantiate -I .envrc | nix show-derivation -f derivation.nix -I .envrc | jq +# - nix-instantiate | nix show-derivation --recursive | jq +# - nix-instantiate -I .envrc | nix show-derivation -f derivation.nix --recursive -I .envrc | jq +# - nix-instantiate | nix-build +# - nix-instantiate -I .envrc | nix-build -I .envrc + +# - nix shell -c default.nix + +# - nix shell -f default.nix --print-build-logs + +# - nix build -I .envrc --print-build-logs --pure +# - nix build -f default.nix --print-build-logs --pure +# - nix build -f derivation.nix --print-build-logs --pure + +# - nix build `nix-instantiate` +# - nix build `nix-instantiate -I .envrc` + +# - nix build -f default.nix && ./result/bin/spine -v && noti -t "spine build" -m "see ./result/bin/spine" + +# - nix run default.nix --print-build-logs +# - nix run -I .envrc default.nix --print-build-logs + +# - nix develop --build -f derivation.nix -I .envrc --print-build-logs |