diff options
author | Ralph Amissah <ralph.amissah@gmail.com> | 2021-09-20 20:02:10 -0400 |
---|---|---|
committer | Ralph Amissah <ralph.amissah@gmail.com> | 2021-10-22 21:28:50 -0400 |
commit | 85a2a2922673bfe44461e26b68cb1da0de5bb8c7 (patch) | |
tree | 974d815fecc851c9212bc0056c9df39a5a36c977 /shell.nix | |
parent | org latex organize (diff) |
nix related config, direnv else minor
Diffstat (limited to 'shell.nix')
-rwxr-xr-x | shell.nix | 66 |
1 files changed, 34 insertions, 32 deletions
@@ -1,41 +1,43 @@ #!/usr/bin/env -S nix-shell --pure { pkgs ? import <nixpkgs> {} }: pkgs.mkShell { - buildInputs = with pkgs; [( - with pkgs; [ - # nix_related - nixFlakes - nix-prefetch-git - validatePkgConfig - jq - git - # d_build_related - rund - dub - ldc - #meson - # # search_sqlite_related - # sqlite - # # pdf_latex_related - # source-sans-pro - # source-serif-pro - # source-code-pro - # texlive.combined.scheme-full - # # xml_and_epub_related - # libxml2 - # html-tidy - # xmlstarlet - # epubcheck - # ebook_tools - # epr - # sigil - # calibre # (ebook-viewer) - # foliate - ] - )]; + buildInputs = with pkgs; [ + # nix_related + nixFlakes + nix-prefetch-git + validatePkgConfig + jq + git + # d_build_related + rund + dub + ldc + #meson + # candy + starship + # # search_sqlite_related + # # search related + # sqlite + # # pdf_latex_related + # source-sans-pro + # source-serif-pro + # source-code-pro + # texlive.combined.scheme-full + # # xml_and_epub_related + # libxml2 + # html-tidy + # xmlstarlet + # epubcheck + # ebook_tools + # epr + # sigil + # calibre # (ebook-viewer) + # foliate + ]; shellHook = '' if [[ -e ".envrc" ]]; then source .envrc fi + eval "$(starship init bash)" ''; } |