{
  description = "a sisu like document parser search form";
  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
  inputs.flake-utils.url = "github:numtide/flake-utils";
  inputs.d-overlay = {
    url = "git://git.sisudoc.org/package/dlang-nix-overlays-and-flake";
    inputs.nixpkgs.follows = "nixpkgs";
    flake = true;
  };
  outputs = {
    self,
    nixpkgs,
    flake-utils,
    d-overlay,
  } @ inputs: let
    pname = "spine_search";
    version = "0.16.0";
    shell = ./shell.nix;
    devEnv = ./nixDevEnv.sh;
    supportedSystems = ["x86_64-linux"];
    forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
    nixpkgsFor = forAllSystems (system: import nixpkgs {inherit system;}); # nixpkgs instantiated for supported system types
    checkPhase = ''
      runHook preCheck
      dub test --combined --skip-registry=all
      runHook postCheck
    '';
    localOverlay = (final: prev: {
      ldc = prev.callPackage ./nix-overlays/ldc {  };
      dmd = prev.callPackage ./nix-overlays/dmd {  };
      dub = prev.callPackage ./nix-overlays/dub {  };
      #gdc = prev.callPackage ./nix-overlays/gdc {  };
    });
    pkgsForSystem = system: import nixpkgs {
      overlays = [
        localOverlay
      ];
      inherit system;
    };
    preBuild = ''
      export HOME=$(pwd)
    '';
    installPhase = ''
      runHook preInstall
      mkdir -p $out/share/cgi-bin
      install -m755 -D ./cgi-bin/spine_search $out/share/cgi-bin/spine_search
      runHook postInstall
    '';
    postInstall = ''
      echo `ls -la $out/share/cgi-bin/spine_search`
    '';
  in {
    packages = forAllSystems (system: let
      pkgs-ovl = pkgsForSystem system;
      pkgs-nix = nixpkgsFor.${system};
    in
      with pkgs-nix; {
        default = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = [sqlite];
          nativeBuildInputs = [dub ldc gnumake];
          buildPhase = ''
            runHook preBuild
            for DC_ in dmd ldmd2 ldc2 gdc gdmd; do
              echo "- check for D compiler $DC_"
              DC=$(type -P $DC_ || echo "")
              if [ ! "$DC" == "" ]; then break; fi
            done
            if [ "$DC" == "" ]; then exit "Error: could not find D compiler"; fi
            echo "$DC_ used as D compiler to build $pname"
            buildCMD="dub run --cache=local --compiler=$DC --build=$DC_ --combined --skip-registry=all"
            echo $buildCMD
            $buildCMD
            echo $buildCMD
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        spine-search-nixpkgs-dmd = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          meta.mainProgram = "spine_search-dmd";
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = [sqlite];
          nativeBuildInputs = [dub dmd gnumake];
          buildPhase = ''
            runHook preBuild
            buildCMD="dub run --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all"
            echo $buildCMD
            $buildCMD
            echo $buildCMD
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        spine-search-nixpkgs-ldc = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          meta.mainProgram = "spine_search-ldc";
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = [sqlite];
          nativeBuildInputs = [dub ldc gnumake];
          buildPhase = ''
            runHook preBuild
            buildCMD="dub run --cache=local --compiler=$(type -P ldmd2) --build=ldmd2 --combined --skip-registry=all"
            echo $buildCMD
            $buildCMD
            echo $buildCMD
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        spine-search-overlay-dmd = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          meta.mainProgram = "spine_search-dmd";
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = with pkgs-ovl; [sqlite];
          nativeBuildInputs = with pkgs-ovl; [dub dmd gnumake];
          buildPhase = ''
            runHook preBuild
            buildCMD="dub run --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all"
            echo $buildCMD
            $buildCMD
            echo $buildCMD
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        spine-search-overlay-ldc = stdenv.mkDerivation {
          inherit pname;
          inherit version;
          meta.mainProgram = "spine_search-ldc";
          executable = true;
          src = self;
          inherit shell;
          inherit devEnv;
          buildInputs = with pkgs-ovl; [sqlite];
          nativeBuildInputs = with pkgs-ovl; [dub ldc gnumake];
          buildPhase = ''
            runHook preBuild
            buildCMD="dub run --cache=local --compiler=$(type -P ldmd2) --build=ldmd2 --combined --skip-registry=all"
            echo $buildCMD
            $buildCMD
            echo $buildCMD
            runHook postBuild
          '';
          inherit preBuild;
          inherit checkPhase;
          inherit installPhase;
          inherit postInstall;
        };
        #spine-search-overlay-gdc = stdenv.mkDerivation {
        #  inherit pname;
        #  inherit version;
        #  meta.mainProgram = "spine_search-gdc";
        #  executable = true;
        #  src = self;
        #  inherit shell;
        #  inherit devEnv;
        #  buildInputs = with pkgs-ovl; [ sqlite ];
        #  nativeBuildInputs = with pkgs-ovl; [ dub gdc gnumake ];
        #  buildPhase = ''
        #    runHook preBuild
        #    dub run --cache=local --compiler=$(type -P gdc) --build=gdc --combined --skip-registry=all
        #    runHook postBuild
        #  '';
        #  inherit preBuild;
        #  inherit checkPhase;
        #  inherit installPhase;
        #  inherit postInstall;
        #};
        #vendorSha256 = "sha256-0Q00000000000000000000000000000000000000000=";
      });
    devShells = forAllSystems (system: let
      pkgs-ovl = pkgsForSystem system;
      pkgs-nix = nixpkgsFor.${system};
      shellHook = ''
        export Date=`date "+%Y%m%d"`
        ## set local values in .envrc-local (or here if you must)
      '';
    in
      with pkgs-nix; {
        dsh-d-overlay = d-overlay.devShells.${system}.default;
        dsh-overlay = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          packages = with pkgs-ovl; [
            ldc
            #dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-nixpkgs-dmd-dub = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          packages = [
            dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-nixpkgs-ldc-dub = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-overlay-dmd-dub = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          packages = with pkgs-ovl; [
            dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-overlay-ldc-dub = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          packages = with pkgs-ovl; [
            ldc
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-sqlite = mkShell {
          name = "spine dev shell for latex & pdf output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        default = import ./shell.nix {inherit pkgs-nix;};
      });
  };
}