{
  description = "spine (sisu like parser & document generator) made available to process markup samples";
  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
  inputs.flake-utils.url = "github:numtide/flake-utils";
  inputs.spine = {
    url = "git://git.sisudoc.org/software/sisudoc-spine";
    inputs.nixpkgs.follows = "nixpkgs";
    flake = true;
  };
  inputs.d-overlay = {
    url = "git://git.sisudoc.org/package/dlang-nix-overlays-and-flake";
    inputs.nixpkgs.follows = "nixpkgs";
    flake = true;
  };
  outputs = {
    self,
    nixpkgs,
    flake-utils,
    spine,
    d-overlay,
  } @ inputs: let
    version = "0.16.0";
    shell = ./shell.nix;
    devEnv = ./nixDevEnv.sh;
    supportedSystems = ["x86_64-linux"]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
    forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
    nixpkgsFor = forAllSystems (system: import nixpkgs {inherit system;}); # nixpkgs instantiated for supported system types
  in {
    packages = forAllSystems (system: let
      pkgs = nixpkgsFor.${system};
    in {
      default = spine.packages.${system}.default;
      spine-nixpkgs-dmd = spine.packages.${system}.spine-nixpkgs-dmd;
      spine-overlay-dmd = spine.packages.${system}.spine-overlay-dmd;
      spine-nixpkgs-ldc = spine.packages.${system}.spine-nixpkgs-ldc;
      spine-overlay-ldc = spine.packages.${system}.spine-overlay-ldc;
      #vendorSha256 = "sha256-0Q00000000000000000000000000000000000000000=";
    });
    apps = forAllSystems (system: {
      default = {
        type = "app";
        program = "${self.packages.${system}.default}/bin/spine";
      };
    });
    devShells = forAllSystems (system: let
      pkgs = nixpkgsFor.${system};
      shellHook = ''
        export DFLAGS="-O2 -boundscheck=on"
        export Date=`date "+%Y%m%d"`
        ## set local values in .envrc-local (or here if you must)
      '';
    in
      with pkgs; {
        dsh = mkShell {
          name = "spine base dev shell";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-spine = spine.devShells.${system}.default;
        dsh-overlay-dmd = d-overlay.devShells.${system}.dsh-overlay-dmd-dub;
        dsh-nixpkgs-dmd = d-overlay.devShells.${system}.dsh-nixpkgs-dmd-dub;
        dsh-overlay-ldc = d-overlay.devShells.${system}.dsh-overlay-ldc-dub;
        dsh-nixpkgs-ldc = d-overlay.devShells.${system}.dsh-nixpkgs-ldc-dub;
        dsh-epub = mkShell {
          name = "spine dev shell for epub output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
            libxml2
            html-tidy
            xmlstarlet
            epubcheck
            ebook_tools
            libxml2
            html-tidy
            xmlstarlet
            epubcheck
            ebook_tools
            epr
            sigil
            calibre #(suite includes: ebook-viewer)
            koreader
            foliate
          ];
          inherit shellHook;
        };
        dsh-html = mkShell {
          name = "spine dev shell for latex & pdf output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-latex-pdf = mkShell {
          name = "spine dev shell for latex & pdf output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            source-sans-pro
            source-serif-pro
            source-code-pro
            texlive.combined.scheme-full
          ];
          inherit shellHook;
        };
        dsh-sqlite = mkShell {
          name = "spine dev shell for latex & pdf output";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
          ];
          inherit shellHook;
        };
        dsh-i18n = mkShell {
          name = "spine dev shell internationalization, po4a";
          inherit shell;
          inherit devEnv;
          packages = [
            ldc
            #dmd
            dub
            gnumake
            sqlite
            perl538Packages.Po4a
          ];
          inherit shellHook;
        };
        default = import ./shell.nix {inherit pkgs;};
      });
  };
}