aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules39
1 files changed, 39 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..5c3307d7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,39 @@
+#!/usr/bin/make -f
+#export DH_VERBOSE=1
+
+build:
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ # Installing lintian overrides
+ for lintian in debian/lintian/*; \
+ do \
+ install -D -m 644 $$lintian debian/`basename $$lintian`/usr/share/lintian/overrides/`basename $$lintian` || exit 1; \
+ done
+
+binary-arch: build install
+
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs README
+ dh_installchangelogs CHANGELOG
+ dh_installman
+ dh_install
+ dh_compress -X.rb -X.ssi -X.ssm -X.sst -X.yml
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: clean build install binary-indep binary-arch binary