aboutsummaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
-rw-r--r--.envrc8
-rw-r--r--.gitignore67
-rw-r--r--org/sisu_build.org169
-rwxr-xr-xshell.nix39
-rw-r--r--sisu.gemspec18
5 files changed, 266 insertions, 35 deletions
diff --git a/.envrc b/.envrc
index 6bb4547e..c0adda9e 100644
--- a/.envrc
+++ b/.envrc
@@ -1,4 +1,8 @@
NIX_ENFORCE_PURITY=0
-if [ -e .envrc-local ]; then # source an additional user-specific .envrc in ./.envrc-local
- source .envrc-local
+if ! has nix_direnv_version || ! nix_direnv_version 1.4.0; then
+# https://github.com/nix-community/nix-direnv
+ source_url "https://raw.githubusercontent.com/nix-community/nix-direnv/1.4.0/direnvrc" "sha256-4XfVDjv75eHMWN4G725VW7BoOV4Vl3vAabK4YXIfPyE="
+fi
+if [ -e .env/local ]; then
+ source_env_if_exists .env/local || source .env/local
fi
diff --git a/.gitignore b/.gitignore
index 321ba4a7..50e88cab 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,18 +1,77 @@
# git ls-files --others --exclude-from=.git/info/exclude
+*
+!README
+!COPYRIGHT
+!CHANGELOG
+!CHANGELOGS/
+!CHANGELOGS/CHANGELOG
+!CHANGELOGS/CHANGELOG_v*
+!makefile
+!Rakefile
+!Rantfile
+!qi
+!setup/
+!setup/*
+!version
+!version.txt
+!conf/
+!conf/**
+!*.json
+!*.org
+!*.rb
+!*.txt
+!*.yml
+!*.nix
+!nix/
+!nix/**
+!org/
+!bin
+!bin/sisu
+!bin/sisu-*
+!bin/sisugem
+!lib
+!lib/**
+!man
+!man/**
+!data
+!data/doc
+!data/doc/**
+!data/sisu
+!data/sisu/**
+!*.sst
+!*.ssm
+!**/*.sst
+!**/*.ssm
+!debian/
+!debian/changelog
+!debian/compat
+!debian/control
+!debian/copyright
+!debian/gbp.conf
+!debian/sisu*.manpages
+!debian/sisu*.install
+!debian/manpages/
+!debian/manpages/sisu*.7
+!debian/rules
+!debian/sisu\.*
+!debian/source/
+!debian/source/format
+!debian/watch
*~
*_
\#*
*.\#*
*.tmp
*_tmp
-.*
*.gem
*.gemspec
-!.gitignore
-!.envrc
+!sisu.gemspec
*_.rb
*.rb_
-.pc
0???-*.patch
*.gz
*.xz
+*_
+.*
+!.gitignore
+!.envrc
diff --git a/org/sisu_build.org b/org/sisu_build.org
index c9d05937..b0f32dfd 100644
--- a/org/sisu_build.org
+++ b/org/sisu_build.org
@@ -2531,8 +2531,12 @@ end
#+HEADER: :tangle ../.envrc
#+BEGIN_SRC sh
NIX_ENFORCE_PURITY=0
-if [ -e .envrc-local ]; then # source an additional user-specific .envrc in ./.envrc-local
- source .envrc-local
+if ! has nix_direnv_version || ! nix_direnv_version 1.4.0; then
+# https://github.com/nix-community/nix-direnv
+ source_url "https://raw.githubusercontent.com/nix-community/nix-direnv/1.4.0/direnvrc" "sha256-4XfVDjv75eHMWN4G725VW7BoOV4Vl3vAabK4YXIfPyE="
+fi
+if [ -e .env/local ]; then
+ source_env_if_exists .env/local || source .env/local
fi
#+END_SRC
@@ -2562,22 +2566,56 @@ export RUBYLIB+=`pwd`/lib
#+HEADER: :tangle-mode (identity #o755)
#+BEGIN_SRC nix
{ pkgs ? import <nixpkgs> {} }:
-pkgs.mkShell {
- buildInputs = [(
- with pkgs; [
- <<ruby_current>>
- <<packages_project_relevant>>
- <<packages_build>>
- ]
- )];
+with pkgs;
+mkShell {
+ buildInputs = [
+ <<ruby_current>>
+ <<packages_project_relevant>>
+ <<packages_build>>
+ <<packages_extra>>
+ ];
shellHook = ''
if [[ -e ".envrc" ]]; then
source .envrc
fi
+ eval "$(starship init bash)"
'';
}
#+END_SRC
+#+BEGIN_SRC nix
+#!/usr/bin/env -S nix-shell --pure
+{ pkgs ? import <nixpkgs> {} }:
+with pkgs;
+mkShell {
+ buildInputs = [
+ ruby_3_1
+ rubyPackages_3_1.rake
+ rubyPackages_3_1.sqlite3
+ rubyPackages_3_1.thor
+ sqlite
+ unzip
+ xz
+ zip
+ openssl
+ #texlive-combined-full
+ nixFlakes
+ validatePkgConfig
+ jq
+ git
+ ### candy
+ starship
+ ];
+ shellHook = ''
+ if [[ -e ".envrc" ]]; then
+ source .envrc
+ fi
+ eval "$(starship init bash)"
+ '';
+}
+#+END_SRC
+
+
#+HEADER: :NO-tangle ../shell.nix
#+BEGIN_SRC nix
{ pkgs ? import <nixpkgs> {} }:
@@ -2718,6 +2756,11 @@ jq
git
#+END_SRC
+#+NAME: packages_extra
+#+BEGIN_SRC nix
+starship
+#+END_SRC
+
* descriptions
** README
@@ -5987,6 +6030,112 @@ Configure substitution in _sisu/sisu_document_make
data/sisu/conf/editor-syntax-etc/emacs/
data/sisu/conf/editor-syntax-etc/emacs/sisu-mode.el
+** git
+*** gitignore
+
+#+HEADER: :tangle ../.gitignore
+#+BEGIN_SRC sh
+# git ls-files --others --exclude-from=.git/info/exclude
+*
+!README
+!COPYRIGHT
+!CHANGELOG
+!CHANGELOGS/
+!CHANGELOGS/CHANGELOG
+!CHANGELOGS/CHANGELOG_v*
+!makefile
+!Rakefile
+!Rantfile
+!qi
+!setup/
+!setup/*
+!version
+!version.txt
+!conf/
+!conf/**
+!*.json
+!*.org
+!*.rb
+!*.txt
+!*.yml
+!*.nix
+!nix/
+!nix/**
+!org/
+!bin
+!bin/sisu
+!bin/sisu-*
+!bin/sisugem
+!lib
+!lib/**
+!man
+!man/**
+!data
+!data/doc
+!data/doc/**
+!data/sisu
+!data/sisu/**
+!*.sst
+!*.ssm
+!**/*.sst
+!**/*.ssm
+!debian/
+!debian/changelog
+!debian/compat
+!debian/control
+!debian/copyright
+!debian/gbp.conf
+!debian/sisu*.manpages
+!debian/sisu*.install
+!debian/manpages/
+!debian/manpages/sisu*.7
+!debian/rules
+!debian/sisu\.*
+!debian/source/
+!debian/source/format
+!debian/watch
+*~
+*_
+\#*
+*.\#*
+*.tmp
+*_tmp
+*.gem
+*.gemspec
+!sisu.gemspec
+*_.rb
+*.rb_
+0???-*.patch
+*.gz
+*.xz
+*_
+.*
+!.gitignore
+!.envrc
+#+END_SRC
+
+##+HEADER: :tangle ../.gitignore
+#+BEGIN_SRC sh
+# git ls-files --others --exclude-from=.git/info/exclude
+,*~
+,*_
+\#*
+,*.\#*
+,*.tmp
+,*_tmp
+.*
+,*.gem
+,*.gemspec
+!.gitignore
+!.envrc
+,*_.rb
+,*.rb_
+.pc
+0???-*.patch
+,*.gz
+,*.xz
+#+END_SRC
+
*** todo
sisu_todo.org
diff --git a/shell.nix b/shell.nix
index 704a2da1..9f689127 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,27 +1,28 @@
#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
-pkgs.mkShell {
- buildInputs = [(
- with pkgs; [
- ruby_3_1
- rubyPackages_3_1.rake
- rubyPackages_3_1.sqlite3
- rubyPackages_3_1.thor
- sqlite
- unzip
- xz
- zip
- openssl
- #texlive-combined-full
- nixFlakes
- validatePkgConfig
- jq
- git
- ]
- )];
+with pkgs;
+mkShell {
+ buildInputs = [
+ ruby_3_1
+ rubyPackages_3_1.rake
+ rubyPackages_3_1.sqlite3
+ rubyPackages_3_1.thor
+ sqlite
+ unzip
+ xz
+ zip
+ openssl
+ #texlive-combined-full
+ nixFlakes
+ validatePkgConfig
+ jq
+ git
+ starship
+ ];
shellHook = ''
if [[ -e ".envrc" ]]; then
source .envrc
fi
+ eval "$(starship init bash)"
'';
}
diff --git a/sisu.gemspec b/sisu.gemspec
new file mode 100644
index 00000000..696525cc
--- /dev/null
+++ b/sisu.gemspec
@@ -0,0 +1,18 @@
+Gem::Specification.new do |s|
+ s.name = 'sisu'
+ s.version = '7.2.1'
+ s.date = '2019-09-05'
+ s.summary = 'documents - structuring, publishing in multiple formats & search (linux calls)'
+ s.description = 'documents - structuring, publishing in multiple formats & search [7.2.1 from git 7.2.1_pre_rel] (linux calls & without external dependencies)'
+ s.homepage = 'http://www.sisudoc.org'
+ s.authors = ["Ralph Amissah"]
+ s.email = 'ralph.amissah@gmail.com'
+ s.license = 'GPL-3.0-or-later'
+ s.files = Dir['lib/sisu.rb'] +
+ Dir['lib/sisu/*.rb'] +
+ Dir['data/sisu/version.yml'] +
+ Dir['data/sisu/image/*'] +
+ Dir['bin/sisugem'] +
+ Dir['bin/sisu']
+ s.executables << 'sisugem' << 'sisu'
+end