aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2022-04-28 12:21:24 -0400
committerRalph Amissah <ralph@amissah.com>2022-04-28 12:21:24 -0400
commit70d190dd7c1f13270e5acac8ec64e113b917ec8d (patch)
tree70b2c52aaad12ca1ff85f3c2c10284060cc05144 /shell.nix
parentdebian/changelog (7.2.0-1) (diff)
parentproject config minor, also .gitignore (diff)
Merge tag 'sisu_7.2.1' into debian
SiSU 7.2.1
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100755
index 00000000..9f689127
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,28 @@
+#!/usr/bin/env -S nix-shell --pure
+{ pkgs ? import <nixpkgs> {} }:
+with pkgs;
+mkShell {
+ buildInputs = [
+ ruby_3_1
+ rubyPackages_3_1.rake
+ rubyPackages_3_1.sqlite3
+ rubyPackages_3_1.thor
+ sqlite
+ unzip
+ xz
+ zip
+ openssl
+ #texlive-combined-full
+ nixFlakes
+ validatePkgConfig
+ jq
+ git
+ starship
+ ];
+ shellHook = ''
+ if [[ -e ".envrc" ]]; then
+ source .envrc
+ fi
+ eval "$(starship init bash)"
+ '';
+}