aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup/qi_libs.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2015-05-01 18:51:40 -0400
committerRalph Amissah <ralph@amissah.com>2015-05-01 18:51:40 -0400
commit58d01ddb946f666b2bc70b867314c00b1e78b1e3 (patch)
tree6ed99ea64d1ad4b02a1c8f901fb6248af9abfe08 /setup/qi_libs.rb
parentdebian/changelog (5.8.0-1) (diff)
parentversion & changelog, tag for release (diff)
Merge tag 'sisu_6.5.0' into debian/sid
SiSU 6.5.0
Diffstat (limited to 'setup/qi_libs.rb')
-rw-r--r--setup/qi_libs.rb16
1 files changed, 12 insertions, 4 deletions
diff --git a/setup/qi_libs.rb b/setup/qi_libs.rb
index cad5e68a..938724a0 100644
--- a/setup/qi_libs.rb
+++ b/setup/qi_libs.rb
@@ -5,9 +5,15 @@ module Project_details
def self.name
'SiSU'
end
+ def self.summary
+ 'documents - structuring, publishing in multiple formats and search'
+ end
def self.description
'documents - structuring, publishing in multiple formats and search'
end
+ def self.homepage
+ 'http://www.sisudoc.org'
+ end
def self.thor
"ruby-thor files for the installation/setup of #{name}"
end
@@ -554,18 +560,20 @@ summary: #{vi[:project]}
Gem::Specification.new do |s|
s.name = '#{vi[:project].downcase}'
s.version = '#{vi[:version_number]}'
- s.date = '#{vi[:date]}'
- s.summary = '#{Version_info.version_number_info(vi)}'
- s.description = '#{Project_details.description}'
s.authors = ["Ralph Amissah"]
s.email = 'ralph.amissah@gmail.com'
+ s.date = '#{vi[:date]}'
+ s.summary = '#{Project_details.summary} #{Version_info.version_number_info(vi)}'
+ s.description = '#{Project_details.description} #{Version_info.version_number_info(vi)} (without external dependencies)'
+ s.homepage = '#{Project_details.homepage}'
+ s.license = 'GPL3'
s.files = Dir['lib/#{Project_details.name.downcase}/#{branch}/*.rb'] +
Dir['data/#{Project_details.name.downcase}/version/#{branch}.yml'] +
Dir['data/#{Project_details.name.downcase}/image/*'] +
Dir['bin/#{Project_details.name.downcase}gem'] +
Dir['bin/#{Project_details.name.downcase}']
- s.license = 'GPL3'
s.executables << '#{Project_details.name.downcase}gem' << '#{Project_details.name.downcase}'
+ s.has_rdoc = false
end
WOK
end