aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v6/txt_plain.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-08 00:21:14 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-08 00:21:14 -0400
commit03f79b10f928c7bb7791b7ea3ee9e8222eb15cc9 (patch)
tree9f1f7de42705f734d8d456f3708db19146804ecf /lib/sisu/v6/txt_plain.rb
parentdebian/changelog (5.5.5-1) (diff)
parentv6: hub, further changes related to use of opt.act; hub file split (diff)
Merge tag 'sisu_5.5.6' into debian/sid
SiSU 5.5.6
Diffstat (limited to 'lib/sisu/v6/txt_plain.rb')
-rw-r--r--lib/sisu/v6/txt_plain.rb6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/sisu/v6/txt_plain.rb b/lib/sisu/v6/txt_plain.rb
index 3f54e749..69008276 100644
--- a/lib/sisu/v6/txt_plain.rb
+++ b/lib/sisu/v6/txt_plain.rb
@@ -63,7 +63,7 @@
=end
module SiSU_Txt_Plain
require_relative 'ao' # ao.rb
- require_relative 'sysenv' # sysenv.rb
+ require_relative 'se' # se.rb
include SiSU_Env
require_relative 'shared_metadata' # shared_metadata.rb
require_relative 'txt_shared' # txt_shared.rb
@@ -122,7 +122,7 @@ module SiSU_Txt_Plain
#wrap_width=(defined? md.make.plaintext_wrap) ? md.make.plaintext_wrap : 78
SiSU_Txt_Plain::Source::Scroll.new(md,ao_array,wrap_width).songsheet
rescue
- SiSU_Errors::Rescued.new($!,$@,@opt.cmd,@opt.fns).location do
+ SiSU_Errors::Rescued.new($!,$@,@opt.selections.str,@opt.fns).location do
__LINE__.to_s + ':' + __FILE__
end
ensure
@@ -139,7 +139,7 @@ module SiSU_Txt_Plain
@env=SiSU_Env::InfoEnv.new(@md.fns)
@brace_url=SiSU_Viz::Defaults.new.url_decoration
@tab="\t"
- @@endnotes_=case md.opt.mod.inspect
+ @@endnotes_=case md.opt.selections.str
when /--footnote/ then false
when /--endnote/ then true
else true