aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v6/texinfo.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-08 00:21:14 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-08 00:21:14 -0400
commit03f79b10f928c7bb7791b7ea3ee9e8222eb15cc9 (patch)
tree9f1f7de42705f734d8d456f3708db19146804ecf /lib/sisu/v6/texinfo.rb
parentdebian/changelog (5.5.5-1) (diff)
parentv6: hub, further changes related to use of opt.act; hub file split (diff)
Merge tag 'sisu_5.5.6' into debian/sid
SiSU 5.5.6
Diffstat (limited to 'lib/sisu/v6/texinfo.rb')
-rw-r--r--lib/sisu/v6/texinfo.rb6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/sisu/v6/texinfo.rb b/lib/sisu/v6/texinfo.rb
index 459d3ac5..509afdd7 100644
--- a/lib/sisu/v6/texinfo.rb
+++ b/lib/sisu/v6/texinfo.rb
@@ -62,7 +62,7 @@
=end
module SiSU_TexInfo
require_relative 'html' # html.rb
- require_relative 'param' # param.rb
+ require_relative 'dp' # dp.rb
include SiSU_Param
include SiSU_Viz
#include Stamp ... needed removed arbitrarily 2005w05/1 (warnings about undefined flags)
@@ -132,7 +132,7 @@ module SiSU_TexInfo
@marshalfile=SiSU_Env::InfoFile.new(@opt.fns).marshal.ao_content
if FileTest.file?(@marshalfile)==true
File.open(@marshalfile) { |f| @@tuned_file=Marshal.load(f)}
- #tell.meta_verse_skipped if @opt.cmd =~/[vVM]/
+ #tell.meta_verse_skipped if @opt.selections.str =~/[vVM]/
else
tex_array=IO.readlines(@opt.fns,'')
SiSU_Metaverse.songsheet(tex_array)
@@ -418,7 +418,7 @@ module SiSU_TexInfo
pwd=Dir.pwd
case sfx
when /(?:-|ssm\.)?sst$/
- @env=SiSU_Env::InfoEnv.new(@md.fns,@md.opt.cmd)
+ @env=SiSU_Env::InfoEnv.new(@md.fns,@md.opt.selections.str)
Dir.chdir(@env.processing_path.texi)
texinfo=SiSU_Env::SystemCall.new("#{fnb}.texinfo")
texinfo.makeinfo