aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v6/qrcode.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-08 00:21:14 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-08 00:21:14 -0400
commit03f79b10f928c7bb7791b7ea3ee9e8222eb15cc9 (patch)
tree9f1f7de42705f734d8d456f3708db19146804ecf /lib/sisu/v6/qrcode.rb
parentdebian/changelog (5.5.5-1) (diff)
parentv6: hub, further changes related to use of opt.act; hub file split (diff)
Merge tag 'sisu_5.5.6' into debian/sid
SiSU 5.5.6
Diffstat (limited to 'lib/sisu/v6/qrcode.rb')
-rw-r--r--lib/sisu/v6/qrcode.rb29
1 files changed, 15 insertions, 14 deletions
diff --git a/lib/sisu/v6/qrcode.rb b/lib/sisu/v6/qrcode.rb
index b9aee5a2..aa31236c 100644
--- a/lib/sisu/v6/qrcode.rb
+++ b/lib/sisu/v6/qrcode.rb
@@ -61,13 +61,13 @@
=end
module SiSU_QRcode
- require_relative 'sysenv' # sysenv.rb
+ require_relative 'se' # se.rb
include SiSU_Env
require_relative 'prog_text_translation' # prog_text_translation.rb
- require_relative 'particulars' # particulars.rb
+ require_relative 'se_hub_particulars' # se_hub_particulars.rb
include SiSU_Particulars
require_relative 'html' # html.rb
- require_relative 'param' # param.rb
+ require_relative 'dp' # dp.rb
include SiSU_Param
require_relative 'i18n' # i18n.rb
include SiSU_Viz
@@ -111,7 +111,7 @@ module SiSU_QRcode
data=SiSU_HTML::Source::HTML_Environment.new(@particulars).tuned_file_instructions
OutputInfo.new(@md).check_output(data)
rescue
- SiSU_Errors::Rescued.new($!,$@,@opt.cmd,@opt.fns).location do
+ SiSU_Errors::Rescued.new($!,$@,@opt.selections.str,@opt.fns).location do
__LINE__.to_s + ':' + __FILE__
end
ensure
@@ -152,7 +152,7 @@ module SiSU_QRcode
mn += x
end
manifest.close if @md.opt.act[:maintenance][:set]==:on
- cmd=SiSU_Env::SystemCall.new(mn,@f.place_file.qrcode_md.dir,@md.opt.cmd)
+ cmd=SiSU_Env::SystemCall.new(mn,@f.place_file.qrcode_md.dir,@md.opt.selections.str)
cmd.qrencode
end
def output_metadata_short
@@ -160,7 +160,7 @@ module SiSU_QRcode
@manifest[:txt_title].each do |x|
mn += x
end
- cmd=SiSU_Env::SystemCall.new(mn,@f.place_file.qrcode_title.dir,@md.opt.cmd)
+ cmd=SiSU_Env::SystemCall.new(mn,@f.place_file.qrcode_title.dir,@md.opt.selections.str)
cmd.qrencode
end
def summarize(id,file,pth='',rel='',url='',img='● ')
@@ -193,7 +193,7 @@ WOK
|| @md.opt.act[:verbose_plus][:set]==:on \
|| @md.opt.act[:maintenance][:set]==:on)
SiSU_Screen::Ansi.new(
- @md.opt.cmd,
+ @md.opt.selections.str,
"#{dgst[1]} #{file}"
).warn
end
@@ -403,12 +403,13 @@ WOK
summarize(id,file,pth,rel,url)
end
if FileTest.file?(@f.place_file.txt.dir)==true
- id=if @md.opt.cmd =~/a/ then 'Plaintext (Unix (UTF-8) with footnotes)'
- elsif @md.opt.cmd =~/e/ then 'Plaintext (Unix (UTF-8) with endnotes)'
- elsif @md.opt.cmd =~/A/ then 'Plaintext (dos (UTF-8) with footnotes)'
- elsif @md.opt.cmd =~/E/ then 'Plaintext (dos (UTF-8) with endnotes)'
- else 'Plaintext (UTF-8)'
- end
+ id='Plaintext (UTF-8)'
+ #id=if @md.opt.selections.str =~/a/ then 'Plaintext (Unix (UTF-8) with footnotes)'
+ #elsif @md.opt.selections.str =~/e/ then 'Plaintext (Unix (UTF-8) with endnotes)'
+ #elsif @md.opt.selections.str =~/A/ then 'Plaintext (dos (UTF-8) with footnotes)'
+ #elsif @md.opt.selections.str =~/E/ then 'Plaintext (dos (UTF-8) with endnotes)'
+ #else 'Plaintext (UTF-8)'
+ #end
pth=@f.output_path.txt.dir
rel=@f.output_path.txt.rel_sm
url=@f.output_path.txt.url
@@ -746,7 +747,7 @@ WOK
output_metadata
output_metadata_short
rescue
- SiSU_Errors::Rescued.new($!,$@,@md.opt.cmd,@md.fns).location do
+ SiSU_Errors::Rescued.new($!,$@,@md.opt.selections.str,@md.fns).location do
__LINE__.to_s + ':' + __FILE__
end
ensure