aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v6/html_lite_shared.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-02-05 01:28:30 -0500
committerRalph Amissah <ralph@amissah.com>2014-02-05 01:28:30 -0500
commitba017314c06829b8d8a92a85d2111a8582c4e1cc (patch)
treeae413a3c2eacce20422b238e0a57c16d5632adf8 /lib/sisu/v6/html_lite_shared.rb
parentdebian/changelog (5.3.0-1) (diff)
parentREADME & manpage (sisu.1) update (diff)
Merge tag 'sisu_5.3.1' into debian/sid
SiSU 5.3.1
Diffstat (limited to 'lib/sisu/v6/html_lite_shared.rb')
-rw-r--r--lib/sisu/v6/html_lite_shared.rb7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/sisu/v6/html_lite_shared.rb b/lib/sisu/v6/html_lite_shared.rb
index b675fbd3..88510f04 100644
--- a/lib/sisu/v6/html_lite_shared.rb
+++ b/lib/sisu/v6/html_lite_shared.rb
@@ -83,6 +83,7 @@ module SiSU_FormatShared
end
@tab="\t"
@brace_url=SiSU_Viz::Defaults.new.url_decoration
+ @ocn_html_identifier=SiSU_Env::ProcessingSettings.new(@md).ocn_html_identifier
@@tablehead,@@tablefoot=[],[]
@vz=SiSU_Viz::Defaults.new
@env=SiSU_Env::InfoEnv.new(@md.fns)
@@ -205,7 +206,7 @@ GSUB
%{<p class="#{h[:class]}" type="#{h[:type]}">#{h[:txt]}</a></p>\n} << "\n"
end
def lev_toc_hname
- %{<p class="toc#{@lv}" header="#{@hname}"><a href="##{@ocn}">#{@txt}</a></p>\n} #<< "\n"
+ %{<p class="toc#{@lv}" header="#{@hname}"><a href="##{@ocn_html_identifier}#{@ocn}">#{@txt}</a></p>\n} #<< "\n"
end
def lev_toc
h={ txt: txt, class: "toc#{@lv}", type: 'toc' }
@@ -309,10 +310,10 @@ GSUB
def paragraph
attrib=%{class="#{@attrib}" }
if @ocn
- id=%{id="#{@ocn}" }
+ id=%{id="#{Mx[:ocn_id_char]}#{@ocn}" }
type=%{type="substantive" }
else
- id=%{id="none" }
+ id=''
type=%{type="comment" }
end
header=%{header="#{@hname}" } if @hname