aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v6/harvest.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-08-08 00:21:14 -0400
committerRalph Amissah <ralph@amissah.com>2014-08-08 00:21:14 -0400
commit03f79b10f928c7bb7791b7ea3ee9e8222eb15cc9 (patch)
tree9f1f7de42705f734d8d456f3708db19146804ecf /lib/sisu/v6/harvest.rb
parentdebian/changelog (5.5.5-1) (diff)
parentv6: hub, further changes related to use of opt.act; hub file split (diff)
Merge tag 'sisu_5.5.6' into debian/sid
SiSU 5.5.6
Diffstat (limited to 'lib/sisu/v6/harvest.rb')
-rw-r--r--lib/sisu/v6/harvest.rb8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/sisu/v6/harvest.rb b/lib/sisu/v6/harvest.rb
index be0efe1a..f32480fe 100644
--- a/lib/sisu/v6/harvest.rb
+++ b/lib/sisu/v6/harvest.rb
@@ -65,10 +65,10 @@
module SiSU_Harvest
@@the_idx_topics,@@the_idx_authors={},{}
class Source
- require_relative 'options' # options.rb
+ require_relative 'hub_options' # hub_options.rb
require_relative 'harvest_topics' # harvest_topics.rb
require_relative 'harvest_authors' # harvest_authors.rb
- require_relative 'sysenv' # sysenv.rb
+ require_relative 'se' # se.rb
include SiSU_Env
def initialize(opt)
@opt=opt
@@ -76,7 +76,7 @@ module SiSU_Harvest
end
def read
begin
- harvest_pth="#{@env.path.webserv}/#{@opt.base_stub}"
+ harvest_pth=@env.path.webserv + '/' + @opt.base_stub
FileUtils::mkdir_p(harvest_pth) unless FileTest.directory?(harvest_pth)
cases(@opt,@env)
rescue
@@ -99,7 +99,7 @@ WOK
style.close
end
def cases(opt,env)
- case opt.mod.inspect
+ case opt.selections.str.inspect
when/--harvest/i
css(opt) if @opt.act[:maintenance][:set]==:on
SiSU_HarvestAuthors::Songsheet.new(opt,env).songsheet