aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/remote.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2014-07-22 21:56:23 -0400
committerRalph Amissah <ralph@amissah.com>2014-07-22 21:56:23 -0400
commit162c6f42bfbbdd4c8c4153bfe6781e83b768326f (patch)
tree5dbc8a659fba4b1e902501f7f26fcd6b69d6c2dd /lib/sisu/v5/remote.rb
parentdebian/changelog (5.5.1-1) (diff)
parentdocumentation related (diff)
Merge tag 'sisu_5.5.2' into debian/sid
SiSU 5.5.2
Diffstat (limited to 'lib/sisu/v5/remote.rb')
-rw-r--r--lib/sisu/v5/remote.rb54
1 files changed, 45 insertions, 9 deletions
diff --git a/lib/sisu/v5/remote.rb b/lib/sisu/v5/remote.rb
index 191b2edc..672eff9e 100644
--- a/lib/sisu/v5/remote.rb
+++ b/lib/sisu/v5/remote.rb
@@ -73,35 +73,67 @@ module SiSU_Remote
@remote=SiSU_Env::InfoRemote.new(opt)
end
def rsync
- SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],'Remote placement ->',@put).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
+ SiSU_Screen::Ansi.new(
+ @opt.act[:color_state][:set],
+ 'Remote placement ->',
+ @put
+ ).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
@remote.rsync.document
end
def rsync_base
- SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],'Remote placement ->','rsync').dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
+ SiSU_Screen::Ansi.new(
+ @opt.act[:color_state][:set],
+ 'Remote placement ->',
+ 'rsync'
+ ).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
@remote.rsync.site_base
end
def rsync_base_sync
- SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],'Remote placement ->','rsync and sync').dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
+ SiSU_Screen::Ansi.new(
+ @opt.act[:color_state][:set],
+ 'Remote placement ->',
+ 'rsync and sync'
+ ).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
@remote.rsync.site_base_sync
end
def rsync_sitemaps
- SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],'Remote placement sitemaps ->','rsync').dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
+ SiSU_Screen::Ansi.new(
+ @opt.act[:color_state][:set],
+ 'Remote placement sitemaps ->',
+ 'rsync'
+ ).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
@remote.rsync_sitemaps
end
def rsync_harvest
- SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],'Remote placement metadata harvest ->','rsync_harvest').dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
+ SiSU_Screen::Ansi.new(
+ @opt.act[:color_state][:set],
+ 'Remote placement metadata harvest ->',
+ 'rsync_harvest'
+ ).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
@remote.rsync.site_harvest
end
def scp
- SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],'Remote placement ->',@put).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
+ SiSU_Screen::Ansi.new(
+ @opt.act[:color_state][:set],
+ 'Remote placement ->',
+ @put
+ ).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
@remote.scp.document
end
def scp_base
- SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],'Remote placement of base site ->','excluding images').dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
+ SiSU_Screen::Ansi.new(
+ @opt.act[:color_state][:set],
+ 'Remote placement of base site ->',
+ 'excluding images'
+ ).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
@remote.scp.site_base
end
def scp_base_all
- SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],'Remote placement ->','complete').dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
+ SiSU_Screen::Ansi.new(
+ @opt.act[:color_state][:set],
+ 'Remote placement ->',
+ 'complete'
+ ).dark_grey_title_hi unless @opt.act[:quiet][:set]==:on
@remote.scp.site_base_all
end
end
@@ -109,7 +141,11 @@ module SiSU_Remote
def initialize(opt,get_s)
@opt,@get_s=opt,get_s
@msg,@msgs='',nil
- @tell=lambda { SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],@msg,"#{@msgs.inspect if @msgs}") }
+ @tell=lambda {
+ SiSU_Screen::Ansi.new(@opt.act[:color_state][:set],
+ @msg,
+ "#{@msgs.inspect if @msgs}")
+ }
end
def fns
begin