aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/harvest_authors.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-07-30 21:42:02 -0400
committerRalph Amissah <ralph@amissah.com>2013-07-30 21:42:02 -0400
commitd15713b728f0c923837e6c417d095e5e1fe2d443 (patch)
treeb293b1310a352fb99b5bd7a3b6fed46ba49b9a46 /lib/sisu/v5/harvest_authors.rb
parentdebian/changelog (4.1.7-1) (diff)
parentv5: cgi helper script, sample search form, single form, monolingual option (diff)
Merge tag 'sisu_4.1.8' into debian/sid
SiSU 4.1.8
Diffstat (limited to 'lib/sisu/v5/harvest_authors.rb')
-rw-r--r--lib/sisu/v5/harvest_authors.rb5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/sisu/v5/harvest_authors.rb b/lib/sisu/v5/harvest_authors.rb
index c20558df..c78971e4 100644
--- a/lib/sisu/v5/harvest_authors.rb
+++ b/lib/sisu/v5/harvest_authors.rb
@@ -364,12 +364,13 @@ WOK
@output[lng][:html_mnt] << x
end
@output[lng][:html] << x
+ lang_code_insert=SiSU_Env::FilenameLanguageCodeInsert.new(@opt,lng).language_code_insert
works=[]
a[1][:md].each do |i|
manifest_at=if @env.output_dir_structure.by? == :language
- i[:file] + '.html'
+ i[:file] + Sfx[:html]
elsif @env.output_dir_structure.by? == :filetype
- i[:file] + '.' + lng + '.html'
+ i[:file] + '.' + lang_code_insert + Sfx[:html]
elsif @env.output_dir_structure.by? == :filename
"./#{i[:file]}/#{i[:page]}"
else '' #error