aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/harvest.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-10-23 23:59:57 -0400
committerRalph Amissah <ralph@amissah.com>2013-10-23 23:59:57 -0400
commit8605801052c23ea408951b4d4054cb90d9caf1f6 (patch)
treeee82b5108ccc570222ba3f0fd72418a85ca70344 /lib/sisu/v5/harvest.rb
parentdebian/changelog (4.2.7-1) (diff)
parentv4 v5: dal, collapsed levels implemented (diff)
Merge tag 'sisu_4.2.8' into debian/sid
SiSU 4.2.8
Diffstat (limited to 'lib/sisu/v5/harvest.rb')
-rw-r--r--lib/sisu/v5/harvest.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sisu/v5/harvest.rb b/lib/sisu/v5/harvest.rb
index ffcb6aa3..8ff7cc31 100644
--- a/lib/sisu/v5/harvest.rb
+++ b/lib/sisu/v5/harvest.rb
@@ -100,10 +100,10 @@ WOK
def cases(opt,env)
case opt.mod.inspect
when/--harvest/i
- css(opt) if opt.cmd.inspect =~/M/
+ css(opt) if @opt.act[:maintenance][:set]==:on
SiSU_HarvestAuthors::Songsheet.new(opt,env).songsheet
SiSU_HarvestTopics::Songsheet.new(opt,env).songsheet
- if opt.cmd.inspect =~/R/
+ if @opt.act[:rsync][:set]==:on
require_relative 'remote' # remote.rb
SiSU_Remote::Put.new(opt).rsync_harvest
end