aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/epub.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-08-21 23:22:34 -0400
committerRalph Amissah <ralph@amissah.com>2013-08-21 23:22:34 -0400
commit2c5b71e36a335fc89c5198259166ed7de478819c (patch)
tree6e7abab3e67b2735428a3d0bf80baa964864b29d /lib/sisu/v5/epub.rb
parentdebian/changelog (4.1.11-1) (diff)
parentv5: vim syntax additions, sisu.vim (diff)
Merge tag 'sisu_4.1.12' into debian/sid
SiSU 4.1.12
Diffstat (limited to 'lib/sisu/v5/epub.rb')
-rw-r--r--lib/sisu/v5/epub.rb12
1 files changed, 6 insertions, 6 deletions
diff --git a/lib/sisu/v5/epub.rb b/lib/sisu/v5/epub.rb
index 960ddd68..26f1dc0d 100644
--- a/lib/sisu/v5/epub.rb
+++ b/lib/sisu/v5/epub.rb
@@ -107,7 +107,7 @@ module SiSU_EPUB
SiSU_EPUB::Source::Seg.new(@md,data).songsheet
SiSU_EPUB::Source::Output.new(@md).songsheet
rescue
- SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ SiSU_Errors::Rescued.new($!,$@,@opt.cmd,@opt.fns).location do
__LINE__.to_s + ':' + __FILE__
end
ensure
@@ -338,7 +338,7 @@ module SiSU_EPUB
@@toc[:seg] << toc[:seg]
@@toc[:scr] << toc[:seg]
rescue
- SiSU_Errors::InfoError.new($!,$@,@md.opt.cmd,@md.fns).error do
+ SiSU_Errors::Rescued.new($!,$@,@md.opt.cmd,@md.fns).location do
__LINE__.to_s + ':' + __FILE__
end
end
@@ -635,7 +635,7 @@ module SiSU_EPUB
end
out.close
rescue
- SiSU_Errors::InfoError.new($!,$@,@md.opt.cmd,@md.fns).error do
+ SiSU_Errors::Rescued.new($!,$@,@md.opt.cmd,@md.fns).location do
__LINE__.to_s + ':' + __FILE__
end
end
@@ -650,7 +650,7 @@ module SiSU_EPUB
end
out.close
rescue
- SiSU_Errors::InfoError.new($!,$@,@md.opt.cmd,@md.fns).error do
+ SiSU_Errors::Rescued.new($!,$@,@md.opt.cmd,@md.fns).location do
__LINE__.to_s + ':' + __FILE__
end
end
@@ -724,7 +724,7 @@ WOK
filename_xhtml.close
end
rescue
- SiSU_Errors::InfoError.new($!,$@,@md.opt.cmd,@md.fns).error do
+ SiSU_Errors::Rescued.new($!,$@,@md.opt.cmd,@md.fns).location do
__LINE__.to_s + ':' + __FILE__
end
end
@@ -742,7 +742,7 @@ WOK
filename_xhtml.close
end
rescue
- SiSU_Errors::InfoError.new($!,$@,@md.opt.cmd,@md.fns).error do
+ SiSU_Errors::Rescued.new($!,$@,@md.opt.cmd,@md.fns).location do
__LINE__.to_s + ':' + __FILE__
end
end