aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/db_drop.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-10-23 23:59:57 -0400
committerRalph Amissah <ralph@amissah.com>2013-10-23 23:59:57 -0400
commit8605801052c23ea408951b4d4054cb90d9caf1f6 (patch)
treeee82b5108ccc570222ba3f0fd72418a85ca70344 /lib/sisu/v5/db_drop.rb
parentdebian/changelog (4.2.7-1) (diff)
parentv4 v5: dal, collapsed levels implemented (diff)
Merge tag 'sisu_4.2.8' into debian/sid
SiSU 4.2.8
Diffstat (limited to 'lib/sisu/v5/db_drop.rb')
-rw-r--r--lib/sisu/v5/db_drop.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sisu/v5/db_drop.rb b/lib/sisu/v5/db_drop.rb
index 252a311b..33029501 100644
--- a/lib/sisu/v5/db_drop.rb
+++ b/lib/sisu/v5/db_drop.rb
@@ -149,7 +149,7 @@ module SiSU_DbDrop
end
end
def base #% drop base indexes
- print "\n drop documents common indexes\n" unless @opt.cmd =~/q/
+ print "\n drop documents common indexes\n" unless @opt.act[:quiet][:set]==:on
sql_arr=[
%{DROP INDEX idx_title;},
%{DROP INDEX idx_author;},
@@ -176,7 +176,7 @@ module SiSU_DbDrop
conn_execute_array(sql_arr)
end
def text #% drop TEXT indexes, sqlite
- print "\n drop documents TEXT indexes\n" unless @opt.cmd =~/q/
+ print "\n drop documents TEXT indexes\n" unless @opt.act[:quiet][:set]==:on
sql_arr=[
%{DROP INDEX idx_clean;},
%{DROP INDEX idx_endnote},