aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v5/dal_doc_objects.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-08-21 23:22:34 -0400
committerRalph Amissah <ralph@amissah.com>2013-08-21 23:22:34 -0400
commit2c5b71e36a335fc89c5198259166ed7de478819c (patch)
tree6e7abab3e67b2735428a3d0bf80baa964864b29d /lib/sisu/v5/dal_doc_objects.rb
parentdebian/changelog (4.1.11-1) (diff)
parentv5: vim syntax additions, sisu.vim (diff)
Merge tag 'sisu_4.1.12' into debian/sid
SiSU 4.1.12
Diffstat (limited to 'lib/sisu/v5/dal_doc_objects.rb')
-rw-r--r--lib/sisu/v5/dal_doc_objects.rb27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/sisu/v5/dal_doc_objects.rb b/lib/sisu/v5/dal_doc_objects.rb
index 64ddbfb1..b2be6105 100644
--- a/lib/sisu/v5/dal_doc_objects.rb
+++ b/lib/sisu/v5/dal_doc_objects.rb
@@ -423,6 +423,33 @@ module SiSU_DAL_DocumentStructure
self
end
end
+ class ObjectFlag
+ attr_accessor :obj,:is,:of,:flag,:mod,:tmp
+ def initialize
+ @of=:flag
+ @is=@obj=@flag=@mod=@tmp=nil
+ end
+ def flag(h,o=nil)
+ of= @of #String, classification - group
+ is= :flag #String, classification - specific type
+ obj= nil #String, text content
+ flag= h[:flag] || ((defined? o.flag) ? o.flag : nil) #String, text content
+ mod= h[:mod] || ((defined? o.mod) ? o.mod : nil) #String, text content
+ tmp= h[:flag] || ((defined? o.tmp) ? o.tmp : nil) #available for processing, empty after use
+ @of,@is,@obj,@flag,@mod,@tmp=of,is,obj,flag,mod,tmp
+ self
+ end
+ def flag_ocn(h,o=nil)
+ of= @of #String, classification - group
+ is= :flag_ocn #String, classification - specific type
+ obj= nil #String, text content
+ flag= h[:flag] || ((defined? o.flag) ? o.flag : nil) #String, text content
+ mod= h[:mod] || ((defined? o.mod) ? o.mod : nil) #String, text content
+ tmp= h[:flag] || ((defined? o.tmp) ? o.tmp : nil) #available for processing, empty after use
+ @of,@is,@obj,@flag,@mod,@tmp=of,is,obj,flag,mod,tmp
+ self
+ end
+ end
class ObjectLayout
attr_accessor :obj,:is,:of,:from,:tmp
def initialize