aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/webrick.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-06-25 00:11:09 -0400
committerRalph Amissah <ralph@amissah.com>2013-06-25 00:11:09 -0400
commitb3006eb0268887ec481c4d46e4602a3a9a2275e8 (patch)
tree54d8b4fb9f0c2744aa6096b546fe6277c184d273 /lib/sisu/v4/webrick.rb
parentdebian/changelog (4.1.5-1) (diff)
parentv4: general code cleaning, sync with v5 (diff)
Merge tag 'sisu_4.1.6' into debian/sid
SiSU 4.1.6
Diffstat (limited to 'lib/sisu/v4/webrick.rb')
-rw-r--r--lib/sisu/v4/webrick.rb3
1 files changed, 1 insertions, 2 deletions
diff --git a/lib/sisu/v4/webrick.rb b/lib/sisu/v4/webrick.rb
index d873f841..1b1b6bd8 100644
--- a/lib/sisu/v4/webrick.rb
+++ b/lib/sisu/v4/webrick.rb
@@ -74,7 +74,6 @@ module SiSU_Webserv
@env=SiSU_Env::InfoEnv.new
port=SiSU_Env::InfoPort.new
@host=@env.url.webrick
- host='localhost'
@port=port.webrick
@serve=[]
Dir.foreach(@env.path.webserv) do |x|
@@ -124,7 +123,7 @@ module SiSU_Webserv
page.p {page.b{"Webrick Served Directories: "}} +
WOK
#% wb_s2 (mounts)
- @mount.each do |x,y| wb_s2 <<<<WOK
+ @mount.each do |x,y| wb_s2 << <<WOK
page.p {page.b{'<a href="#{@host}:#{@port}#{x}/">#{x}</a> '} + '<a href="#{@host}:#{@port}#{x}/">#{@host}:#{@port}#{x}</a> (mounts: #{y}/) <a href="#{@host}:#{@port}#{x}/wb.cgi">info (wb.cgi)</a>'} +
WOK
end