aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/param.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-04-08 20:06:11 -0400
committerRalph Amissah <ralph@amissah.com>2013-04-08 20:06:11 -0400
commit64e5514f4b05ac5f54c564e1fb4ba33b64a7e3bb (patch)
tree70292ae31c0fa54d024a31e9210ef4cef2b7e7ad /lib/sisu/v4/param.rb
parentdebian/changelog (4.0.18-1) (diff)
parentv4: version & changelog, dates touched (diff)
Merge tag 'sisu_4.0.19' into debian/sid
SiSU 4.0.19
Diffstat (limited to 'lib/sisu/v4/param.rb')
-rw-r--r--lib/sisu/v4/param.rb20
1 files changed, 4 insertions, 16 deletions
diff --git a/lib/sisu/v4/param.rb b/lib/sisu/v4/param.rb
index 035697c9..b8e582eb 100644
--- a/lib/sisu/v4/param.rb
+++ b/lib/sisu/v4/param.rb
@@ -1320,7 +1320,8 @@ module SiSU_Param
: papersize_array_rc
fn=@opt.fno #decide what to do a filesize on .ssm tells very little about actual document size
@filesize=(File.size(fn)).to_s
- if @sys.openssl !=false
+ if @sys.openssl !=false \
+ and FileTest.file?(@env.source_file_with_path)
@dgst=[]
if @env.digest.type =~/sha256/
dgst=@sys.sha256(@env.source_file_with_path)
@@ -1331,6 +1332,8 @@ module SiSU_Param
@dgst=dgst[1].length==32 ? dgst : nil
puts 'check document (md5) digest' if not @dgst
end
+ elsif not FileTest.file?(@env.source_file_with_path)
+ #puts SiSU_Utils::CodeMarker.new(__LINE__,__FILE__).set(:fuchsia)
end
@publisher ||= "#{@@publisher} (this copy)"
fn_set_lang=SiSU_Env::StandardiseLanguage.new(@opt.lng).language
@@ -1345,23 +1348,8 @@ module SiSU_Param
@language[:name]=fn_set_lang[:n]
end
@fnl=@env.i18n.lang_filename(fn_set_lang[:c])
-#fix
-# @flv.each do |l|
-# lang=SiSU_Env::StandardiseLanguage.new.file_to_language(l)
-# c={ a: '', b: '', c: '' }
-# if @fnl[:pre] =~/\S/ then c[:a]="#{lang[:c]}."
-# elsif @fnl[:mid] =~/\S/ then c[:b]=".#{lang[:c]}"
-# elsif @fnl[:post] =~/\S/ then c[:c]=".#{lang[:c]}"
-# end
-# @lang << [lang[:n],"#{c[:a]}sisu_manifest#{c[:b]}.html#{c[:c]}"]
-# end if @flv
@lang=@lang.uniq
@fn=SiSU_Env::EnvCall.new(@fns).lang(fn_set_lang[:c])
- #if @identifier.is_a?(Array)
- # @identifier[:sisupod]=sisupod_hash_value
- #else @identifier={ sisupod: sisupod_hash_value }
- #end
- #"#{@env.url.root}/#{@fnb}/#{@fn[:toc]}" #DC note constructed dc identifier
if @en[:note] > 0 \
and @en[:sum] > 0
if @en[:sum] > 0