aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/options.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-04-08 20:06:11 -0400
committerRalph Amissah <ralph@amissah.com>2013-04-08 20:06:11 -0400
commit64e5514f4b05ac5f54c564e1fb4ba33b64a7e3bb (patch)
tree70292ae31c0fa54d024a31e9210ef4cef2b7e7ad /lib/sisu/v4/options.rb
parentdebian/changelog (4.0.18-1) (diff)
parentv4: version & changelog, dates touched (diff)
Merge tag 'sisu_4.0.19' into debian/sid
SiSU 4.0.19
Diffstat (limited to 'lib/sisu/v4/options.rb')
-rw-r--r--lib/sisu/v4/options.rb11
1 files changed, 5 insertions, 6 deletions
diff --git a/lib/sisu/v4/options.rb b/lib/sisu/v4/options.rb
index 0608df4e..20499964 100644
--- a/lib/sisu/v4/options.rb
+++ b/lib/sisu/v4/options.rb
@@ -718,6 +718,9 @@ module SiSU_Commandline
end
act[:links_to_manifest]=if mod.inspect =~/"--inc-links-to-manifest"|"--inc-manifest-links"/
{ bool: true, set: :on }
+ elsif mod.inspect =~/"--(?:exc|no)-manifest"/ \
+ || act[:switch][:off].inspect =~/"manifest"/ #place lower
+ { bool: false, set: :off }
elsif mod.inspect =~/"--(?:exc|no)-links-to-manifest"|"--(?:exc|no)-manifest-links"/ \
|| act[:switch][:off].inspect =~/"links_to_manifest"|"manifest_links"|"--(?:exc|no)-manifest"/ \
|| mod.inspect =~/"--(?:redirect|dump)/
@@ -942,10 +945,6 @@ module SiSU_Commandline
|| mod.inspect =~/"--git"/) \
? { bool: true, set: :on }
: { bool: false, set: :na }
- act[:zap]=(cmd =~/Z/ \
- || mod.inspect =~/"--zap"|"--delete"/) \
- ? { bool: true, set: :on }
- : { bool: false, set: :na }
act[:hash_digests]=(cmd =~/N/ \
|| mod.inspect =~/"--hash-digests"/) \
? { bool: true, set: :on }
@@ -974,8 +973,8 @@ module SiSU_Commandline
|| mod.inspect =~/"--rsync"/) \
? { bool: true, set: :on }
: { bool: false, set: :na }
- act[:delete_output]=(cmd =~/z/ \
- || mod.inspect =~/"--delete"|"--zap"/) \
+ act[:zap]=(cmd =~/Z/ \
+ || mod.inspect =~/"--zap"|"--delete"/) \
? { bool: true, set: :on }
: { bool: false, set: :na }
act[:urls_all]=(cmd =~/U/ \