aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/manifest.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-08-28 18:22:27 -0400
committerRalph Amissah <ralph@amissah.com>2013-08-28 18:22:27 -0400
commitdbddd3289c1a7bad5b549698af0a58aa568fcc43 (patch)
treece801cb01286a340ae0220ab74dcaae986e800d7 /lib/sisu/v4/manifest.rb
parentdebian/changelog (4.2.0-1) (diff)
parentv5: dal, grouped text with fontface spanning newlines, partial solution, test (diff)
Merge tag 'sisu_4.2.1' into debian/sid
SiSU 4.2.1
Diffstat (limited to 'lib/sisu/v4/manifest.rb')
-rw-r--r--lib/sisu/v4/manifest.rb5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/sisu/v4/manifest.rb b/lib/sisu/v4/manifest.rb
index eb888387..d86830e4 100644
--- a/lib/sisu/v4/manifest.rb
+++ b/lib/sisu/v4/manifest.rb
@@ -841,10 +841,11 @@ WOK
'..'
else '..'
end
+ output_organised_by="(output organised by #{@env.output_dir_structure.by?})"
harvest=(FileTest.file?("#{pth_local}/authors#{@fn_lng}.html") \
&& FileTest.file?("#{pth_local}/topics#{@fn_lng}.html")) \
- ? %{<p class="small"><a href="#{pth_rel_home}/index.html">.:</a> other document manifests: [<a href="#{pth_rel}/authors#{@fn_lng}.html">authors</a>] [<a href="#{pth_rel}/topics#{@fn_lng}.html">topics</a>]</p>}
- : ''
+ ? %{<p class="small"><a href="#{pth_rel_home}/index.html">.:</a> other document manifests: [<a href="#{pth_rel}/authors#{@fn_lng}.html">authors</a>] [<a href="#{pth_rel}/topics#{@fn_lng}.html">topics</a>] #{output_organised_by}</p>}
+ : %{<p class="small"><a href="#{pth_rel_home}/index.html">#{output_organised_by}</p>}
manifest_title=%{<p class="bold">#{@translate.manifest_description}</p>#{harvest}}
@manifest[:html] <<<<WOK
<div id="horizontal_links">