aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/html_segments.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-06-25 00:11:09 -0400
committerRalph Amissah <ralph@amissah.com>2013-06-25 00:11:09 -0400
commitb3006eb0268887ec481c4d46e4602a3a9a2275e8 (patch)
tree54d8b4fb9f0c2744aa6096b546fe6277c184d273 /lib/sisu/v4/html_segments.rb
parentdebian/changelog (4.1.5-1) (diff)
parentv4: general code cleaning, sync with v5 (diff)
Merge tag 'sisu_4.1.6' into debian/sid
SiSU 4.1.6
Diffstat (limited to 'lib/sisu/v4/html_segments.rb')
-rw-r--r--lib/sisu/v4/html_segments.rb12
1 files changed, 5 insertions, 7 deletions
diff --git a/lib/sisu/v4/html_segments.rb b/lib/sisu/v4/html_segments.rb
index 55335845..65034738 100644
--- a/lib/sisu/v4/html_segments.rb
+++ b/lib/sisu/v4/html_segments.rb
@@ -185,7 +185,7 @@ module SiSU_HTML_Seg
end
protected
def articles(data)
- track,tracking,newfile=0,0,0
+ tracking,newfile=0,0
@@is4=@@is3=@@is2=@@is1=0
printed_endnote_seg='n'
idx_html=nil
@@ -200,7 +200,7 @@ module SiSU_HTML_Seg
|| dob.is == :heading_insert) \
&& dob.ln == 4
@@seg_name << dob.name
- seg_name=dob.name
+ dob.name
end
end
@@seg_name_html=@@seg_name
@@ -257,7 +257,7 @@ module SiSU_HTML_Seg
if not (dob.is==:heading \
|| dob.is==:heading_insert) \
&& dob.ln==1
- head1=$_ #; check
+ $_ #; check
end
end
if @@is4==1
@@ -268,8 +268,6 @@ module SiSU_HTML_Seg
|| dob.is==:heading_insert) \
&& dob.ln==4
if tracking != 0
- dirout=SiSU_Env::InfoEnv.new(@md.fns)
- dir_sisu=dirout.path.output
@file=SiSU_Env::FileOp.new(@md)
unless FileTest.directory?(@file.output_path.html_seg.dir)
FileUtils::mkdir_p(@file.output_path.html_seg.dir) if File.writable?("#{@file.output_path.base.dir}/.")
@@ -426,7 +424,7 @@ module SiSU_HTML_Seg
end
def markup(dob)
@debug=[]
- format_head_seg=SiSU_HTML_Format::HeadSeg.new(@md)
+ SiSU_HTML_Format::HeadSeg.new(@md)
if dob.is !=:meta
if dob.is==:heading \
|| dob.is==:heading_insert \
@@ -439,7 +437,7 @@ module SiSU_HTML_Seg
|| dob.is==:para
dob_html=if dob.is==:heading \
|| dob.is==:heading_insert
- x=if dob.ln==4
+ if dob.ln==4
sto.seg_heading4
elsif dob.ln==5
sto.seg_heading5