aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/dbi_discrete.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-06-25 00:11:09 -0400
committerRalph Amissah <ralph@amissah.com>2013-06-25 00:11:09 -0400
commitb3006eb0268887ec481c4d46e4602a3a9a2275e8 (patch)
tree54d8b4fb9f0c2744aa6096b546fe6277c184d273 /lib/sisu/v4/dbi_discrete.rb
parentdebian/changelog (4.1.5-1) (diff)
parentv4: general code cleaning, sync with v5 (diff)
Merge tag 'sisu_4.1.6' into debian/sid
SiSU 4.1.6
Diffstat (limited to 'lib/sisu/v4/dbi_discrete.rb')
-rw-r--r--lib/sisu/v4/dbi_discrete.rb3
1 files changed, 1 insertions, 2 deletions
diff --git a/lib/sisu/v4/dbi_discrete.rb b/lib/sisu/v4/dbi_discrete.rb
index 3499bc9c..5b7d36bf 100644
--- a/lib/sisu/v4/dbi_discrete.rb
+++ b/lib/sisu/v4/dbi_discrete.rb
@@ -151,7 +151,6 @@ module SiSU_DBI_Discrete #% database building
end
def connect
begin
- sql_type='sqlite'
SiSU_Screen::Ansi.new(@opt.cmd,"DBI (#{@sql_type}) #{@opt.mod}",@opt.fns).dbi_title unless @opt.cmd =~/q/
@db.sqlite_discrete.conn_sqlite3
rescue
@@ -165,7 +164,7 @@ module SiSU_DBI_Discrete #% database building
end
def sql_maintenance_file
file=if @opt.inspect =~/M/
- x=if @opt.fns and not @opt.fns.empty?
+ if @opt.fns and not @opt.fns.empty?
@env=SiSU_Env::InfoEnv.new(@opt.fns) if @opt.fns
puts "\n#{@env.processing_path.sqlite}/#{@opt.fns}.sql" if @sql_type =~/sqlite/ and @opt.cmd =~/M/
@db=SiSU_Env::InfoDb.new