aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/dal_idx.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-06-25 00:11:09 -0400
committerRalph Amissah <ralph@amissah.com>2013-06-25 00:11:09 -0400
commitb3006eb0268887ec481c4d46e4602a3a9a2275e8 (patch)
tree54d8b4fb9f0c2744aa6096b546fe6277c184d273 /lib/sisu/v4/dal_idx.rb
parentdebian/changelog (4.1.5-1) (diff)
parentv4: general code cleaning, sync with v5 (diff)
Merge tag 'sisu_4.1.6' into debian/sid
SiSU 4.1.6
Diffstat (limited to 'lib/sisu/v4/dal_idx.rb')
-rw-r--r--lib/sisu/v4/dal_idx.rb3
1 files changed, 1 insertions, 2 deletions
diff --git a/lib/sisu/v4/dal_idx.rb b/lib/sisu/v4/dal_idx.rb
index 87196029..96486858 100644
--- a/lib/sisu/v4/dal_idx.rb
+++ b/lib/sisu/v4/dal_idx.rb
@@ -130,7 +130,7 @@ module SiSU_DAL_BookIndex
idx_lst=idx[:rough_idx].scan(/[^|:]+/)
idx_lst[0]=idx_lst[0].strip
if idx_lst[0] =~/.+?\+\d+/
- use,plus=/(.+?)\+(\d+)/.match(idx_lst[0])[1,2]
+ use=/(.+?)\+(?:\d+)/.match(idx_lst[0])[1]
else use=idx_lst[0]
end
use=use[0].chr.capitalize + use[1,use.length]
@@ -282,7 +282,6 @@ module SiSU_DAL_BookIndex
end
end
end
- idx
@x +=1
end
end