aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/dal_idx.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-01-31 21:41:55 -0500
committerRalph Amissah <ralph@amissah.com>2013-01-31 21:41:55 -0500
commitee132f1146cbed3266b448e1cea312375c201cf1 (patch)
tree37498d07d78fa16e21361ccbefeb2adc0d9e6039 /lib/sisu/v4/dal_idx.rb
parentdebian/changelog (4.0.3-1) (diff)
parentv4 (v3): version & changelog, dates touched (diff)
Merge tag 'sisu_4.0.4' into debian/sid
Diffstat (limited to 'lib/sisu/v4/dal_idx.rb')
-rw-r--r--lib/sisu/v4/dal_idx.rb11
1 files changed, 3 insertions, 8 deletions
diff --git a/lib/sisu/v4/dal_idx.rb b/lib/sisu/v4/dal_idx.rb
index 63eb487e..a1d66402 100644
--- a/lib/sisu/v4/dal_idx.rb
+++ b/lib/sisu/v4/dal_idx.rb
@@ -161,12 +161,7 @@ module SiSU_DAL_BookIndex
the_idx
end
def clean_xml(str)
- str=str.gsub(/&/,'&#038;').
- gsub(/\(/,'&#040;').
- gsub(/\)/,'&#041;').
- gsub(/\*/,'&#042;').
- gsub(/\+/,'&#043;').
- gsub(/,/,'&#044;')
+ str=str.gsub(/&/,'&amp;')
str
end
def index(the_idx)
@@ -193,8 +188,8 @@ module SiSU_DAL_BookIndex
idx[:html] << ''
idx[:xhtml] << ''
else
- idx[:html] << %{<a href="##{x}">#{x}</a>,&nbsp;}
- idx[:xhtml] << %{<a href="##{x.downcase}">#{x}</a>,&nbsp;}
+ idx[:html] << %{<a href="##{x}">#{x}</a>,#{$ep[:hsp]}}
+ idx[:xhtml] << %{<a href="##{x.downcase}">#{x}</a>,#{$ep[:hsp]}}
end
end
idx[:html] << '</p>'