aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v4/dal_doc_objects.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-08-25 01:25:49 -0400
committerRalph Amissah <ralph@amissah.com>2013-08-25 01:25:49 -0400
commit77cae1945ed4d01100f42705801cfd12fb8be941 (patch)
tree35bb5e6bd8e03df63af45226d0198d7a522d08ea /lib/sisu/v4/dal_doc_objects.rb
parentdebian/changelog (4.1.12-1) (diff)
parentv4 v5: vim syntax, sisu.vim, improve grouped text match, for blocks using tics (diff)
Merge tag 'sisu_4.2.0' into debian/sid
SiSU 4.2.0
Diffstat (limited to 'lib/sisu/v4/dal_doc_objects.rb')
-rw-r--r--lib/sisu/v4/dal_doc_objects.rb27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/sisu/v4/dal_doc_objects.rb b/lib/sisu/v4/dal_doc_objects.rb
index 12441156..8fdd8068 100644
--- a/lib/sisu/v4/dal_doc_objects.rb
+++ b/lib/sisu/v4/dal_doc_objects.rb
@@ -423,6 +423,33 @@ module SiSU_DAL_DocumentStructure
self
end
end
+ class ObjectFlag
+ attr_accessor :obj,:is,:of,:flag,:mod,:tmp
+ def initialize
+ @of=:flag
+ @is=@obj=@flag=@mod=@tmp=nil
+ end
+ def flag(h,o=nil)
+ of= @of #String, classification - group
+ is= :flag #String, classification - specific type
+ obj= nil #String, text content
+ flag= h[:flag] || ((defined? o.flag) ? o.flag : nil) #String, text content
+ mod= h[:mod] || ((defined? o.mod) ? o.mod : nil) #String, text content
+ tmp= h[:flag] || ((defined? o.tmp) ? o.tmp : nil) #available for processing, empty after use
+ @of,@is,@obj,@flag,@mod,@tmp=of,is,obj,flag,mod,tmp
+ self
+ end
+ def flag_ocn(h,o=nil)
+ of= @of #String, classification - group
+ is= :flag_ocn #String, classification - specific type
+ obj= nil #String, text content
+ flag= h[:flag] || ((defined? o.flag) ? o.flag : nil) #String, text content
+ mod= h[:mod] || ((defined? o.mod) ? o.mod : nil) #String, text content
+ tmp= h[:flag] || ((defined? o.tmp) ? o.tmp : nil) #available for processing, empty after use
+ @of,@is,@obj,@flag,@mod,@tmp=of,is,obj,flag,mod,tmp
+ self
+ end
+ end
class ObjectLayout
attr_accessor :obj,:is,:of,:from,:tmp
def initialize