aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/xml_fictionbook.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-01-23 21:52:37 -0500
committerRalph Amissah <ralph@amissah.com>2012-01-23 21:52:37 -0500
commitdc5c01b1033cfc9e09fd4fc29666e826e67cd7bb (patch)
treee53a389c4f669d79b5b82ce6fd1853da6b25f85d /lib/sisu/v3dv/xml_fictionbook.rb
parentdebian/changelog (3.1.11-1) (diff)
parentv3dv: replace use of most ruby exclamation (!) method actions (diff)
Merge commit 'sisu_3.1.12' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/xml_fictionbook.rb')
-rw-r--r--lib/sisu/v3dv/xml_fictionbook.rb6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/sisu/v3dv/xml_fictionbook.rb b/lib/sisu/v3dv/xml_fictionbook.rb
index 8a0819eb..8fe1e7c1 100644
--- a/lib/sisu/v3dv/xml_fictionbook.rb
+++ b/lib/sisu/v3dv/xml_fictionbook.rb
@@ -151,11 +151,11 @@ WOK
@data.each do |para|
@endnotes << para.scan(/~\{(.+?)\}~/m)
end
- @endnotes.flatten!
+ @endnotes=@endnotes.flatten
end
def endnotes
@endnotes.each do |endnote|
- endnote.strip!
+ endnote=endnote.strip
endnote=@trans.markup_fictionbook(endnote)
endnote="<p>#{endnote}</p>"
util=SiSU_TextUtils::Wrap.new(endnote,80,10)
@@ -171,7 +171,7 @@ WOK
put(tail)
end
def markup(para,type='')
- para.strip!
+ para=para.strip
para=@trans.markup_fictionbook(para)
para=if type.empty?; "<p>#{para}</p>"
else "<#{type}><p>#{para}</p></#{type}>"