aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/texinfo_format.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
committerRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
commit7db7a01a7d86e95159bdef47162dc180accf1acb (patch)
tree156013cdb28b483ac122c26b9f2e199c9a7d9d12 /lib/sisu/v3dv/texinfo_format.rb
parentdebian/changelog (3.1.12-1) (diff)
parentv3dv, dal +, use symbols to identify document objects type (is) and group (of) (diff)
Merge tag 'sisu_3.1.13' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/texinfo_format.rb')
-rw-r--r--lib/sisu/v3dv/texinfo_format.rb5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/sisu/v3dv/texinfo_format.rb b/lib/sisu/v3dv/texinfo_format.rb
index 30d40e20..0555809d 100644
--- a/lib/sisu/v3dv/texinfo_format.rb
+++ b/lib/sisu/v3dv/texinfo_format.rb
@@ -98,7 +98,6 @@ module SiSU_TexInfoFormat
v=SiSU_Env::InfoVersion.instance.get_version
head =<<WOK
\\input texinfo @c -*-texinfo-*-
-@comment $Id$
@comment %**start of header
@setfilename #{@md.fnb}.info
@settitle #{title} @value{VERSION}
@@ -294,7 +293,7 @@ WOK
"@bye"
end
def clean(dob)
- if dob.is=='heading' \
+ if dob.is==:heading \
and dob.obj !~/##{dob.ocn}/
dob.obj="#{dob.obj} ##{dob.ocn}"
end
@@ -557,7 +556,7 @@ WOK
@md,@dob,@txt=md,dob,txt
end
def clean(dob,txt)
- if dob.is=='heading' \
+ if dob.is==:heading \
and txt !~/##{dob.ocn}/
txt="#{dob.obj} ##{dob.ocn}"
end