aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/remote.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-01-23 21:52:37 -0500
committerRalph Amissah <ralph@amissah.com>2012-01-23 21:52:37 -0500
commitdc5c01b1033cfc9e09fd4fc29666e826e67cd7bb (patch)
treee53a389c4f669d79b5b82ce6fd1853da6b25f85d /lib/sisu/v3dv/remote.rb
parentdebian/changelog (3.1.11-1) (diff)
parentv3dv: replace use of most ruby exclamation (!) method actions (diff)
Merge commit 'sisu_3.1.12' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/remote.rb')
-rw-r--r--lib/sisu/v3dv/remote.rb5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/sisu/v3dv/remote.rb b/lib/sisu/v3dv/remote.rb
index 39e929cc..4004e5f8 100644
--- a/lib/sisu/v3dv/remote.rb
+++ b/lib/sisu/v3dv/remote.rb
@@ -143,10 +143,9 @@ module SiSU_Remote
end
if images \
and images.length > 1
- images.flatten!
- images.uniq!
+ images=images.flatten.uniq
images.delete_if {|x| x =~/https?:\/\// }
- images.sort!
+ images=images.sort
@msg,@msgs='downloading images:', [ images.join(',') ]
@tell.call.warn unless @opt.cmd =~/q/
image_info=image_download_url + images