aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/harvest_topics.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-01-23 21:52:37 -0500
committerRalph Amissah <ralph@amissah.com>2012-01-23 21:52:37 -0500
commitdc5c01b1033cfc9e09fd4fc29666e826e67cd7bb (patch)
treee53a389c4f669d79b5b82ce6fd1853da6b25f85d /lib/sisu/v3dv/harvest_topics.rb
parentdebian/changelog (3.1.11-1) (diff)
parentv3dv: replace use of most ruby exclamation (!) method actions (diff)
Merge commit 'sisu_3.1.12' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/harvest_topics.rb')
-rw-r--r--lib/sisu/v3dv/harvest_topics.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sisu/v3dv/harvest_topics.rb b/lib/sisu/v3dv/harvest_topics.rb
index 6bdc7e12..504e0a4d 100644
--- a/lib/sisu/v3dv/harvest_topics.rb
+++ b/lib/sisu/v3dv/harvest_topics.rb
@@ -144,7 +144,7 @@ module SiSU_Harvest_Topics
g=@idx_list.scan(/[^;]+/)
idxl=[]
g.each do |i|
- i.strip!
+ i=i.strip
idxl << { filename: filename, file: file, rough_idx: i, title: @fulltitle, author: creator, page: page, lang: lang }
end
idxl
@@ -153,7 +153,7 @@ module SiSU_Harvest_Topics
else
p "missing required field in #{@filename} - [title]: <<#{@title}>>; [author]: <<#{@author_format}>>; [idx]: <<#{@idx_list}>>" if @opt.cmd.inspect =~/[VM]/
end
- idx_array[lang].flatten!
+ idx_array[lang]=idx_array[lang].flatten
idx_array
end
end