aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/harvest_authors.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-01-23 21:52:37 -0500
committerRalph Amissah <ralph@amissah.com>2012-01-23 21:52:37 -0500
commitdc5c01b1033cfc9e09fd4fc29666e826e67cd7bb (patch)
treee53a389c4f669d79b5b82ce6fd1853da6b25f85d /lib/sisu/v3dv/harvest_authors.rb
parentdebian/changelog (3.1.11-1) (diff)
parentv3dv: replace use of most ruby exclamation (!) method actions (diff)
Merge commit 'sisu_3.1.12' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/harvest_authors.rb')
-rw-r--r--lib/sisu/v3dv/harvest_authors.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sisu/v3dv/harvest_authors.rb b/lib/sisu/v3dv/harvest_authors.rb
index 3d3c2378..fa6934a5 100644
--- a/lib/sisu/v3dv/harvest_authors.rb
+++ b/lib/sisu/v3dv/harvest_authors.rb
@@ -139,7 +139,7 @@ module SiSU_Harvest_Authors
else
#p "missing author field: #{@filename} title: #{@title}; author: #{@author_format}"
end
- idx_array[lang].flatten!
+ idx_array[lang]=idx_array[lang].flatten
idx_array
end
end
@@ -157,7 +157,7 @@ module SiSU_Harvest_Authors
@@the_idx_authors[lang] ||= {}
idx_array.each do |idx|
idx[:author][:last_first_format_a].each do |author|
- author.strip!
+ author=author.strip
if @@the_idx_authors[lang][author].class==NilClass
@@the_idx_authors[lang][author]={ md: [] }
end