aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/dal_hash_digest.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
committerRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
commit7db7a01a7d86e95159bdef47162dc180accf1acb (patch)
tree156013cdb28b483ac122c26b9f2e199c9a7d9d12 /lib/sisu/v3dv/dal_hash_digest.rb
parentdebian/changelog (3.1.12-1) (diff)
parentv3dv, dal +, use symbols to identify document objects type (is) and group (of) (diff)
Merge tag 'sisu_3.1.13' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/dal_hash_digest.rb')
-rw-r--r--lib/sisu/v3dv/dal_hash_digest.rb8
1 files changed, 5 insertions, 3 deletions
diff --git a/lib/sisu/v3dv/dal_hash_digest.rb b/lib/sisu/v3dv/dal_hash_digest.rb
index 40f81197..ad201752 100644
--- a/lib/sisu/v3dv/dal_hash_digest.rb
+++ b/lib/sisu/v3dv/dal_hash_digest.rb
@@ -76,8 +76,10 @@ module SiSU_DAL_Hash
unless t_o.obj.class==Array
t_o.obj=t_o.obj.strip
end
- if t_o.of !~/structure|comment|layout/ \
- and t_o.ocn.class==Fixnum
+ if (t_o.of !=:structure \
+ && t_o.of !=:comment \
+ && t_o.of !=:layout) \
+ && t_o.ocn.class==Fixnum
if sha_
for hash_class in [ Digest::SHA256 ]
@tuned_file << stamped(t_o,hash_class)
@@ -120,7 +122,7 @@ module SiSU_DAL_Hash
stripped=SiSU_TextRepresentation::Alter.new(t_o).strip_clean_of_markup
markup=SiSU_TextRepresentation::Alter.new(t_o).semi_revert_markup
digests=SiSU_TextRepresentation::ModifiedTextPlusHashDigest.new(@md,t_o).composite.dgst
- unless t_o.is=='code'
+ unless t_o.is==:code
case t_o.obj
when /#{Mx[:en_a_o]}[\d*+]+\s+.+?#{Mx[:en_a_c]}|#{Mx[:en_b_o]}[*+]\d+\s+.+?#{Mx[:en_b_c]}/m
en_and_t_o,en_and_t_o_digest=[],[]