aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/dal_expand_insertions.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-03-12 18:51:21 -0400
committerRalph Amissah <ralph@amissah.com>2012-03-12 18:51:21 -0400
commit1b7b1b2aec62cf261faa94ce2fbc05e9c28c83e2 (patch)
tree52b39f3a8e625db1678c3353a2a88a271379d81f /lib/sisu/v3dv/dal_expand_insertions.rb
parentdebian/changelog (3.1.14-1) (diff)
parentv3dv: documentation sisu_commands, add sqlite3 discreet (diff)
Merge tag 'sisu_3.1.15' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/dal_expand_insertions.rb')
-rw-r--r--lib/sisu/v3dv/dal_expand_insertions.rb8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/sisu/v3dv/dal_expand_insertions.rb b/lib/sisu/v3dv/dal_expand_insertions.rb
index 9e675bc4..ef25fcdd 100644
--- a/lib/sisu/v3dv/dal_expand_insertions.rb
+++ b/lib/sisu/v3dv/dal_expand_insertions.rb
@@ -141,7 +141,7 @@ module SiSU_DAL_Insertions
def xml_dom
"#{@base_path}/xml/#{@linked_doc}.xml"
end
- def txt
+ def txt
"#{@base_path}/txt/#{@linked_doc}.txt"
end
def digest
@@ -241,7 +241,7 @@ module SiSU_DAL_Insertions
def xml_dom
"#{@base_path}/scroll.#{@lng}.dom.xml"
end
- def txt
+ def txt
"#{@base_path}/plain.#{@lng}.txt"
end
def digest
@@ -277,10 +277,10 @@ module SiSU_DAL_Insertions
pre=pre.strip
elsif /\{(?<txt>.+?)\s\[(?<cmd>\d[sS]*)\]\}(?<source>(?<linked_doc>\S+?)\.ss[tm]\b)(?<note>.*)/m =~ para
end
- if linked_doc =~ /(\S+?)\/(\S+)/
+ if linked_doc =~ /(\S+?)\/(\S+)/
linked_doc,linked_doc_lang=$1,$2
else
- linked_doc,linked_doc_lang=linked_doc,@md.opt.lng_base
+ linked_doc,linked_doc_lang=linked_doc,@md.opt.lng_base
end
else
puts "error, does currently support relative paths (reltive paths were removed, as had problems for citation, and was not suited to all output types should possibly reconsider) #{__FILE__} #{__LINE__}"