aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/dal_endnotes.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
committerRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
commit7db7a01a7d86e95159bdef47162dc180accf1acb (patch)
tree156013cdb28b483ac122c26b9f2e199c9a7d9d12 /lib/sisu/v3dv/dal_endnotes.rb
parentdebian/changelog (3.1.12-1) (diff)
parentv3dv, dal +, use symbols to identify document objects type (is) and group (of) (diff)
Merge tag 'sisu_3.1.13' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/dal_endnotes.rb')
-rw-r--r--lib/sisu/v3dv/dal_endnotes.rb6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/sisu/v3dv/dal_endnotes.rb b/lib/sisu/v3dv/dal_endnotes.rb
index eb5e3429..191260c4 100644
--- a/lib/sisu/v3dv/dal_endnotes.rb
+++ b/lib/sisu/v3dv/dal_endnotes.rb
@@ -74,9 +74,9 @@ module SiSU_DAL_Endnotes
if @md.opt.mod.inspect =~/--no-dagger|--no-annotate/
dob.obj=dob.obj.gsub(/#{Mx[:en_b_o]}[+]\s.+?#{Mx[:en_b_c]}/,'')
end
- if defined? dob.obj \
- and defined? dob.is \
- and dob.is !~/^code/
+ if (defined? dob.obj) \
+ && (defined? dob.is) \
+ && dob.is !=:code
case dob.obj # auto-numbered endnotes <!e!> <!e_!> -->
when /#{Mx[:en_a_o]}.+?#{Mx[:en_a_c]}|#{Mx[:en_b_o]}[*+]\s+.+?#{Mx[:en_b_c]}/
dob.obj=dob.obj.gsub(/\s*(#{Mx[:en_a_c]}|#{Mx[:en_b_c]})/,' \1') # required 2003w31