aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3dv/concordance.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
committerRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
commit7db7a01a7d86e95159bdef47162dc180accf1acb (patch)
tree156013cdb28b483ac122c26b9f2e199c9a7d9d12 /lib/sisu/v3dv/concordance.rb
parentdebian/changelog (3.1.12-1) (diff)
parentv3dv, dal +, use symbols to identify document objects type (is) and group (of) (diff)
Merge tag 'sisu_3.1.13' into debian/sid
Diffstat (limited to 'lib/sisu/v3dv/concordance.rb')
-rw-r--r--lib/sisu/v3dv/concordance.rb7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/sisu/v3dv/concordance.rb b/lib/sisu/v3dv/concordance.rb
index e51514c3..82c53e7a 100644
--- a/lib/sisu/v3dv/concordance.rb
+++ b/lib/sisu/v3dv/concordance.rb
@@ -115,7 +115,7 @@ module SiSU_Concordance
@fnb=@md.fnb
@lex_button=%{<a href="http://www.jus.uio.no/sisu/" target="_top"><img border="0" height="44" width="144" valign="center" src="#{@file.path_rel_links.html_seg_2}_sisu/image/sisu.png" alt="SiSU home --&gt;"></a>}
@doc_details =<<WOK
-<table summary="links to text related to this rudimentary index" width="96%" border="0" bgcolor="white" cellpadding="0" align="center"><tr><td width="2%" align="right">&nbsp;</td><td width="94%" valign="top" align="justify"><h1 class="small"><a href="#{@md.fn[:toc]}" #{@vz.js_toc}><b>#{@md.title.full}</b></a></h1><p class="bold">#{@md.author}</p></td></tr></table>
+<table summary="links to text related to this rudimentary index" width="96%" border="0" bgcolor="white" cellpadding="0" align="center"><tr><td width="2%" align="right">&nbsp;</td><td width="94%" valign="top" align="justify"><h1 class="small"><a href="#{@md.file.base_filename.html_segtoc}" #{@vz.js_toc}><b>#{@md.title.full}</b></a></h1><p class="bold">#{@md.author}</p></td></tr></table>
WOK
end
def create
@@ -238,8 +238,9 @@ WOK
@dal_array.each do |line|
if defined? line.ocn \
and line.ocn.to_s =~/\d/
- if line.is =~/heading/ \
- and line.ln==4
+ if (line.is ==:heading \
+ || line.is ==:heading_insert) \
+ && line.ln==4
@seg=line.name
end
ocn=line.ocn.to_s