aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/xml_fictionbook.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-05-12 19:30:03 -0400
committerRalph Amissah <ralph@amissah.com>2012-05-12 19:30:03 -0400
commit5774f08063724011fc90eaa7627e6f8660bc690e (patch)
treee8f7be4187ab6ee99d34f9863777b22e02d90e51 /lib/sisu/v3/xml_fictionbook.rb
parentdebian/changelog (3.2.7-1) (diff)
parentv3: sisupod make, re-fixed, check again (diff)
Merge tag 'sisu_3.2.8' into debian/sid
Diffstat (limited to 'lib/sisu/v3/xml_fictionbook.rb')
-rw-r--r--lib/sisu/v3/xml_fictionbook.rb5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/sisu/v3/xml_fictionbook.rb b/lib/sisu/v3/xml_fictionbook.rb
index 8fe1e7c1..3234e146 100644
--- a/lib/sisu/v3/xml_fictionbook.rb
+++ b/lib/sisu/v3/xml_fictionbook.rb
@@ -76,7 +76,10 @@ module SiSU_XML_Fictionbook
@md=SiSU_Param::Parameters.new(@opt).get
@dal_array=SiSU_DAL::Source.new(@opt).get
SiSU_XML_Fictionbook::Source::Scroll.new(@dal_array,@md).songsheet
- rescue; SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error
+ rescue
+ SiSU_Errors::InfoError.new($!,$@,@opt.cmd,@opt.fns).error do
+ __LINE__.to_s + ':' + __FILE__
+ end
ensure
end
end