aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/xhtml.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
committerRalph Amissah <ralph@amissah.com>2012-02-03 20:45:52 -0500
commit7db7a01a7d86e95159bdef47162dc180accf1acb (patch)
tree156013cdb28b483ac122c26b9f2e199c9a7d9d12 /lib/sisu/v3/xhtml.rb
parentdebian/changelog (3.1.12-1) (diff)
parentv3dv, dal +, use symbols to identify document objects type (is) and group (of) (diff)
Merge tag 'sisu_3.1.13' into debian/sid
Diffstat (limited to 'lib/sisu/v3/xhtml.rb')
-rw-r--r--lib/sisu/v3/xhtml.rb7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/sisu/v3/xhtml.rb b/lib/sisu/v3/xhtml.rb
index 7f910e47..6f8c6da5 100644
--- a/lib/sisu/v3/xhtml.rb
+++ b/lib/sisu/v3/xhtml.rb
@@ -83,9 +83,10 @@ module SiSU_XHTML
unless @opt.cmd =~/q/
path=@env.path.output_tell
loc=@env.url.output_tell
-
- tool=if @opt.cmd =~/[MV]/; "#{@env.program.web_browser} file://#{@md.file.output_path.xhtml.dir}/#{@md.file.base_filename.xhtml}#{path}/#{@md.fnb}/#{@md.fn[:xhtml]}\n\t#{@env.program.xml_viewer} file://#{@md.file.output_path.xhtml.dir}/#{@md.file.base_filename.xhtml}#{path}/#{@md.fnb}/#{@md.fn[:xhtml]}"
- elsif @opt.cmd =~/v/; "#{@env.program.web_browser} file://#{@md.file.output_path.xhtml.dir}/#{@md.file.base_filename.xhtml}"
+ tool=if @opt.cmd =~/[MV]/
+ "#{@env.program.web_browser} file://#{@md.file.output_path.xhtml.dir}/#{@md.file.base_filename.xhtml}"
+ elsif @opt.cmd =~/v/
+ "#{@env.program.web_browser} file://#{@md.file.output_path.xhtml.dir}/#{@md.file.base_filename.xhtml}"
else "[#{@opt.f_pth[:lng_is]}] #{@opt.fns}"
end
@opt.cmd=~/[MVvz]/ \