aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/texpdf_format.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-12-02 04:08:26 -0500
committerRalph Amissah <ralph@amissah.com>2011-12-02 04:08:26 -0500
commit13038021f95ffbf38870354ad5ea04ad1b1d8b2d (patch)
tree22070360dd7dea93e864141b07048e8611693c79 /lib/sisu/v3/texpdf_format.rb
parentdebian/changelog (3.1.5-1) (diff)
parentv3: texpdf, use boites for box round codeblocks (diff)
Merge commit 'sisu_3.1.6' into debian/sid
Diffstat (limited to 'lib/sisu/v3/texpdf_format.rb')
-rw-r--r--lib/sisu/v3/texpdf_format.rb4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sisu/v3/texpdf_format.rb b/lib/sisu/v3/texpdf_format.rb
index 34169892..e65f9729 100644
--- a/lib/sisu/v3/texpdf_format.rb
+++ b/lib/sisu/v3/texpdf_format.rb
@@ -80,7 +80,6 @@ module SiSU_TeX_Pdf
end
end
class Format_text_object
- require 'iconv'
require_relative 'defaults' # defaults.rb
attr_accessor :string,:string1,:orientation,:url,:dir,:tex
@@sys=SiSU_Env::System_call.new
@@ -1049,6 +1048,7 @@ WOK
\\usepackage{textcomp}
\\usepackage[parfill]{parskip}
\\usepackage[normalem]{ulem}
+\\usepackage{boites}
\\usepackage{soul}
\\usepackage{longtable}
\\usepackage{graphicx}
@@ -1150,7 +1150,7 @@ WOK
@tex2pdf=@@tex3pdf ||=SiSU_Env::System_call.new.tex2pdf_engine
end
def xetex_special_characters_1(str,is='') # ~ ^ $ & % _ { } #LaTeX special characters - KEEP list
- #str=Iconv.conv('ISO-8859-1', 'UTF-8', @txt)
+ #str=Iconv.conv('ISO-8859-1', 'UTF-8', @txt) # `require': iconv will be deprecated in the future, use String#encode instead.
word=str.scan(/\S+|\n/) #unless line =~/^(?:@\S|%+\s)/
para_array=[]
str=if word