aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/sisupod_make.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2011-11-21 00:16:10 -0500
committerRalph Amissah <ralph@amissah.com>2011-11-21 00:16:10 -0500
commitdc9dad19359b04687b25588c8e8b158e00e6e117 (patch)
tree0bb2c3e145643a6bbff523c2e0411bd7d373e5b6 /lib/sisu/v3/sisupod_make.rb
parentdebian/changelog (3.1.4-1) (diff)
parentv3: odf:odt v1.2 (diff)
Merge commit 'sisu_3.1.5' into debian/sid
Diffstat (limited to 'lib/sisu/v3/sisupod_make.rb')
-rw-r--r--lib/sisu/v3/sisupod_make.rb5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/sisu/v3/sisupod_make.rb b/lib/sisu/v3/sisupod_make.rb
index b154bc1d..e4423641 100644
--- a/lib/sisu/v3/sisupod_make.rb
+++ b/lib/sisu/v3/sisupod_make.rb
@@ -160,8 +160,8 @@ module SiSU_Doc
end
@skin
end
- def images_extract(f,images)
- rgx_image=/(?:^|[^_\\])\{\s*(\S+?\.(?:png|jpg|gif))/
+ def images_extract(f,images) # consider using param info
+ rgx_image=/(?:^|[^_\\])\{(?:\s*|\~\^\s+)(\S+?\.(?:png|jpg|gif)\b)/m
if f !~/^%+\s/ \
and f =~rgx_image
images << f.scan(rgx_image).uniq
@@ -183,6 +183,7 @@ module SiSU_Doc
file_array.each do |f| #% work area
if f !~/^%+\s/
skin << f.scan(@rgx_skin).uniq.flatten if f =~@rgx_skin
+ f.gsub!(/<:=(\S+?)>/,'{ c_\1.png 14x14 }image') # embedded symbol (image)
if f !~/^%+\s/ \
and f =~@rgx_image
images=images_extract(f,images)