aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/screen_text_color.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-05-01 23:39:36 -0400
committerRalph Amissah <ralph@amissah.com>2012-05-01 23:39:36 -0400
commit762b6e9415a6f2708a0d6407180ccad77d1a3249 (patch)
tree692f0d4184f41858c00425b8631c38bd45c91649 /lib/sisu/v3/screen_text_color.rb
parentdebian/changelog (3.2.5-1) (diff)
parentv3: hub (seek finer grained control over what happens when; causes breakage) (diff)
Merge tag 'sisu_3.2.6' into debian/sid
Diffstat (limited to 'lib/sisu/v3/screen_text_color.rb')
-rw-r--r--lib/sisu/v3/screen_text_color.rb2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/sisu/v3/screen_text_color.rb b/lib/sisu/v3/screen_text_color.rb
index 7705e3b1..5dd6109d 100644
--- a/lib/sisu/v3/screen_text_color.rb
+++ b/lib/sisu/v3/screen_text_color.rb
@@ -206,7 +206,7 @@ module SiSU_Screen
def sisu
end
def rescue
- puts %{\t #{@cX.orange}Rescued#{@cX.off} #{@cX.grey}#{yield if block_given?}\n\t An#{@cX.off} #{@cX.fuschia}ERROR#{@cX.off} #{@cX.grey}occurred, message:#{@cX.off} #{@cX.fuschia}#{@txt[0]}#{@cX.off} #{@cX.grey}#{@txt[1]}#{@cX.off} #{@cX.brown}#{@txt[2]}#{@cX.off}}
+ STDERR.puts %{\t #{@cX.orange}Rescued#{@cX.off} #{@cX.grey}#{yield if block_given?}\n\t An#{@cX.off} #{@cX.fuschia}ERROR#{@cX.off} #{@cX.grey}occurred, message:#{@cX.off} #{@cX.fuschia}#{@txt[0]}#{@cX.off} #{@cX.grey}#{@txt[1]}#{@cX.off} #{@cX.brown}#{@txt[2]}#{@cX.off}}
end
def warn
puts "\t #{@cX.brown}#{@txt[0]}#{@cX.off} #{@cX.grey}#{@txt[1]}#{@cX.off}"